Font selection/size preferences lost if caret ("cursor") is moved before typing

RESOLVED DUPLICATE of bug 203810

Status

MailNews Core
Composition
--
minor
RESOLVED DUPLICATE of bug 203810
13 years ago
9 years ago

People

(Reporter: Dan Browne, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040602 Firefox/0.8
Build Identifier: Thunderbird version 0.6 (20040502)

My relevant settings are: default HTML font "fixed width" Reply optoins
Compose messages in HTML format is checked
Automatically quote the original message is checked with options
"start my reply above the quote"
"place sig below the quote"

When I click reply and the compose window appears, initially all is well, i.e.
my default font is selected and the quote and sig are in the right place.

Now if I press the down key to the blank line above the quote the font switches
to "variable width".

The font stays at "variable width" even when I return to the original line!


Reproducible: Always
Steps to Reproduce:
1. Set composition settings / font settings as desribed above
2. Click reply on a message
3. press down cursor key arrow

Actual Results:  
The font changes to "variable width" and remains at this

Expected Results:  
The font should not have changed.

Comment 1

13 years ago
This is a problem for any HTML message containing any pre-inserted automatic 
text; that is, it happens for a reply, an inline forward, or a message with a 
sig.

What happens is, the font-face and size are implemented using <font> and <tt> 
tags that begin at the initial caret location.  But until something *is* typed, 
the tags are not inserted into the buffer.  The overall message body itself -- 
all the automatic text -- is "unformatted" by these tags; and if you move the 
caret away from the insertable text, you lose those formatting tags.

But if you type something first, it gets formatted per preferences; and whenever 
you return to typing from that text, the format continues.  (You can still move 
to a line of the 'automatic text' and type using whatever format is in place 
there, but returning to your own text allows you to regain the formatting.)

The workaround is easy enough: reset the formatting manually; so this bug gets 
downgraded to Minor.

This is similar to the problem in bug 250539; and like that problem, the real 
solution is for Moz to NOT use the <font> and <tt> tags to format the text.  
What is needed is a style sheet -- a few lines of default style in the message's 
<head>, set according to the user's prefs -- and ideally completely 
configurable.  See bug 245007.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Message Compose Window → Composition
Ever confirmed: true
OS: Windows XP → All
Product: Thunderbird → MailNews
Hardware: PC → All
Summary: when replying, font reverts to "variable width" if down key pressed → Font selection/size preferences lost if caret ("cursor") is moved before typing
Version: unspecified → Trunk

Comment 2

13 years ago
Another related: bug 248377.

Comment 3

13 years ago
Found a dupe.

*** This bug has been marked as a duplicate of 203810 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.