Firefox does not open all tabs of a bookmarked tab session because of a malformed link (imported from galeon) wyciwyg://1/ in front of it. its stopps at this position and does not open the tabs after it.

RESOLVED FIXED

Status

()

RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: sagebiel, Assigned: mconnor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.2) (KHTML, like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040602 Firefox/0.8.0+

a bookmark file is attached. its not possible to open all tabs again (open in 
tabs) becaus FF stopps at the malformed url  wyciwyg://1/ (imported from 
galeon) 

Reproducible: Always
Steps to Reproduce:
1.open tab bookmark in tabs (attached bookmarks.html) 
2. 
3. 
 
Actual Results:  
it does not open the tab after the malformed url(second last tab) 

Expected Results:  
open all tabs as in bookmark and handle that malformed url as it is 
doing( doing nothing is correct) but open the good urls after it. 

make a tab session and save it as bookmark tabs 
enter in that session this url and open them all again 
 wyciwyg://1/http://www.pb-versicherung.de/karriere/stellenboerse/indexPBV.jsp
(Reporter)

Comment 1

14 years ago
Created attachment 150023 [details]
open it and it does not open the last tab

open the tab bookmark "bugreport" and reproduce it. the malformed url is
imported from galeon.

Comment 2

14 years ago
I have a similar scenario which I thought I should add here rather than create
another bug.

Version: Firefox 0.9 release on Windows ME

How to reproduce:
1. Create a bookmarks folder with several bookmarks in it (say 10).
2. In this bookmarks folder, add a bookmark to a local HTML file.
3. Move the bookmark to local file so that it appears halfway down the folder
listing.
4. Move/rename the local HTML file that the bookmark points to (thereby making
the bookmark invalid).
5. Start with a new browser window.
6. Select "Open in tabs" on the bookmarks folder.

Result:
Tabs are created for all the bookmarks up and including the local bookmark. At
which point the following error message appears:

"The file /C:/<filename> cannot be found. Please check the location and try again."

This error message halts the "open in tabs" operation, and the rest of the
bookmarks in the folder are not loaded in tabs.

Expected result:
All the bookmarks in the folder should be opened in tabs. The error message
should appear for the local bookmark, but this should not prevent the rest of
the bookmarks from loading.

Additional information:
If the user has selected "open in tabs", he will expect all the pages to appear
in new tabs. The fact that he has an invalid local bookmark should not cause the
action to halt prematurely.

I suggest that the following would be a better summary for this bug:

"An error during "Open in Tabs" operation will prevent the remaining bookmarks
in the folder from being loaded"

Comment 3

14 years ago
*** Bug 263809 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
confirmed with FF trunk build 20050118

Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

14 years ago
Created attachment 171930 [details] [diff] [review]
patch
Assignee: p_ch → mconnor
Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Updated

14 years ago
Blocks: 276169
(Assignee)

Comment 6

12 years ago
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.