nsBlockFrame.cpp fails to compile with accessiblity turned off

RESOLVED FIXED

Status

()

Core
Disability Access APIs
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: Crispin Flowerday (not receiving bug mail), Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040602 Galeon/1.3.15.99
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040602 Galeon/1.3.15.99

mozilla/layout/html/base/src/nsBlockFrame.cpp fails to compile:

make[1]: Entering directory `/space/crispin/mozilla/layout/html/base/src'
nsBlockFrame.cpp
c++ -o nsBlockFrame.o -c -DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\"
-D_IMPL_NS_LAYOUT -I./../../../xul/base/src -I./../../../xul/content/src
-I./../../style/src -I./../../forms/src -I./../../../base/src -I. 
-I../../../../dist/include/xpcom -I../../../../dist/include/string
-I../../../../dist/include/dom -I../../../../dist/include/content
-I../../../../dist/include/gfx -I../../../../dist/include/widget
-I../../../../dist/include/locale -I../../../../dist/include/view
-I../../../../dist/include/necko -I../../../../dist/include/js
-I../../../../dist/include/caps -I../../../../dist/include/pref
-I../../../../dist/include/htmlparser -I../../../../dist/include/webshell
-I../../../../dist/include/plugin -I../../../../dist/include/docshell
-I../../../../dist/include/mimetype -I../../../../dist/include/webbrwsr
-I../../../../dist/include/oji -I../../../../dist/include/util
-I../../../../dist/include/unicharutil -I../../../../dist/include/lwbrk
-I../../../../dist/include/imglib2 -I../../../../dist/include/accessibility
-I../../../../dist/include/xpconnect -I../../../../dist/include/java
-I../../../../dist/include/exthandler -I../../../../dist/include/intl
-I../../../../dist/include/uconv -I../../../../dist/include/layout
-I../../../../dist/include -I/space/crispin/mozilla/dist/include/nspr    
-I/usr/X11R6/include   -fPIC  -I/usr/X11R6/include -fno-rtti -fno-exceptions
-Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic
-fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O  -I/usr/X11R6/include
-DMOZILLA_CLIENT -include ../../../../mozilla-config.h
-Wp,-MD,.deps/nsBlockFrame.pp nsBlockFrame.cpp
nsBlockFrame.cpp:78:37: nsIAccessibilityService.h: No such file or directory
make[1]: *** [nsBlockFrame.o] Error 1
make[1]: Leaving directory `/space/crispin/mozilla/layout/html/base/src'
make: *** [all] Error 2


This is almost certainly broken by the patch for bug 242594

Reproducible: Always
Steps to Reproduce:




about:buildconfig:

--enable-default-toolkit=gtk2 --prefix=/opt/mozilla --enable-xft --enable-crypto
--enable-xterm-updates --enable-chrome-format=jar --disable-mailnews
--disable-ldap --disable-freetype2 --disable-xprint --disable-accessibility
--disable-xpinstall --disable-composer --disable-installer --disable-debug
--disable-dtd-debug --disable-mathml --disable-logging --disable-editor
--disable-jsd --with-system-jpeg --with-system-png --with-system-zlib
--enable-extensions=all --enable-svg --enable-svg-renderer-libart
(Assignee)

Comment 1

14 years ago
Right, this is because dbaron had asked me to remove #ifdef ACCESSIBILITY from
around the #include's

I think the problem is that 
#include "nsIAccessibilityService.h"

doesn't even exist when accessibility is turned off.

Dbaron said:
> Don't ifdef includes unless the file is unavailable otherwise.	See
> http://www.mozilla.org/hacking/portable-cpp.html#dont_ifdef_include
It's nsIServiceManager.h that is available otherwise, which was why I made the
comment.

Looks like aaronl already fixed this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.