js error shows a lot in the js console

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Hussam Al-Tayeb, Assigned: Blake Ross)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking0.9 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040605 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040605 Firefox/0.8.0+

I see error a lot in the js console 

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]" nsresult: "0x80004002
(NS_NOINTERFACE)" location: "JS frame :: chrome://browser/content/browser.js ::
updateGoMenu :: line 813" data: no]



Reproducible: Always
Steps to Reproduce:
1. install firefox using the branch installer
2. Let firefox create a new profile
3. After using firefox for a couple of minutes, you will see 50+ instances of
this error in the js console.
(Reporter)

Comment 1

14 years ago
what exactly does this error mean?
Flags: blocking0.9?

Comment 2

14 years ago
Not blocking unless there is some user-visible regression.
Flags: blocking0.9? → blocking0.9-

Comment 3

14 years ago
Confirmed on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2)
Gecko/20040618 Firefox/0.8.0+.

I experienced the some js error when pressing F5 to reload
http://gmail.google.com/gmail .
The Go menu in the menubar would then lacks a separator on the above of
History(Ctrl + H) item.

At the same time, I got another js error...
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIRDFCompositeDataSource.GetTarget]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://browser/content/browser.js :: updateGoMenu :: line 808"  data: no]

In my experience, the Go -> history does not always record all the pages that
I've visited...

Comment 4

14 years ago
Created attachment 152739 [details]
screenshot showing lack of separator
Is this still showing in FF1.0PR/RC1 ?
Some historystuff was recently fixed.
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> Is this still showing in FF1.0PR/RC1 ?
> Some historystuff was recently fixed.

I don't think so, at least not since 0.10.1
Peter, I marking this as WFM, but reopen it if still get this error.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
thanks Hussam

Comment 8

14 years ago
I can reproduce on Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3)
Gecko/20041015 Firefox/0.10.1
Though this bug is quite bogus and just occasionally occurs.

How can I reopen the bug?
done
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 10

13 years ago
STill an issue?

Comment 11

13 years ago
wfm.
Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.8b) Gecko/20050128 Firefox/1.0+

Comment 12

13 years ago
Also, WFM:Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b)
Gecko/20050130 Firefox/1.0+

Please reopen if you can reproduce with a fresh trunk build
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.