Scrolling with scrollwheel in Toolbar Customize Dialog doesn't work

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Neil Paris, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040604 Firefox/0.8.0+

I have seen this bug both with a Trunk build and a build from the Aviary branch.

When Customizing toolbars, using the scrollwheel to scroll inside the dialog
doesn't work.

Reproducible: Always

Steps to Reproduce:
1) Open the Customize Toolbar Dialog (View>Toolbars>Customize...)
2) Try and scroll the dialog up and down with the scrollwheel. Even after
attempting to focus the window by clicking inside, scrolling by scrollwheel
still fails

Expected Behavior:
The dialog is scrollable

Actual Behavior:
No scrolling by scrollwheel is possible. Scrolling by the arrows on the
scrollbar still works fine.
(Reporter)

Comment 1

14 years ago
I tried this in Windows XP with an Aviary build from today (the 8th of June) and
the Customize dialog had no scrollbar. The "sheet" that came out was long enough
to show all the remaining buttons. Even making the window smaller didn't affect
the "sheet"...it extended past the window's border.

Perhaps this bug is that the customize "sheet" *has* a scrollbar in the
firstplace (at least here on Linux)?
This seems to be fixed on the trunk with the fix for bug 97283 that gave all
sorts of things support for scrollwheel scrolling.
(Reporter)

Comment 3

14 years ago
Yes, it is fixed (more than likely by the fix for bug 97283, as you suggest
Phil) in Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8a6) Gecko/20041210
Firefox/1.0+

Marking WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.