Some GIF appear images decode or display incorrectly.

RESOLVED WORKSFORME

Status

()

Core
ImageLib
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Paul Bergsagel, Assigned: Jim Dunn)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040514

Some, though not all GIF images do not display corretly. This is hard to
discribe. I have included a gif file attachment which demonstrates the problem.

Reproducible: Sometimes
Steps to Reproduce:
1.Surf a page with a GIF which does not display correctly. (See my Gif attachment.)

Actual Results:  
Gifs display incorrectly.

Expected Results:  
Proper GIF display.

Note: I believe some GIFs display correctly while others do not. My knowledge of
the Gif image file format is too limited to know what image file conditions or
settings used to save the GIF may cause the image to display incorrectly. I also
am unsure if this issue is solely with Mozilla 1.7rc2 or with an incompatibility
between Mac OS 10.3.4 since the GIF image issue occured shortly after upgrading
to 10.3.4. I also believe the Gif issue may be rekated the the incorrect display
of icons in the default Mozilla skin on OS X.
(Reporter)

Comment 1

14 years ago
Created attachment 150116 [details]
A GIF image file which fails in Mozilla 1.7RC2

This Gif file display correctly in GIMP and Preview.
(Reporter)

Comment 2

14 years ago
I am closing this bug as worksforme. The display problem with some GIFs and UI
theme icons appers to have been fixed with Mozilla 1.7RC3. I will reopen if I
encounter this issue agin in the future.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.