Closed Bug 245747 Opened 18 years ago Closed 18 years ago

Firefox insists on opening a new window rather than reusing an existing window

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 172962

People

(Reporter: chrisowens, Assigned: bugzilla)

References

Details

(Whiteboard: DUPEME[DDE])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040606 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040606 Firefox/0.8.0+

I use FeedDemon to view my new subscriptions and I tell it [FeedDemon] to open
links in my default external browser (Firefox).

Now, although Firefox opens the link, I am getting a new Window each time,
instead of FeedDemon re-using the browser windows as it should.

On most of the recent branch builds (last 3-4 days), a new window is opened each
time... However it works correctly on the latest trunk build.

Reproducible: Always
Steps to Reproduce:
1. Use a recent branch build.
2. Tell FeedDemon to use default browser.
3. Click a link in FeedDemon.

Actual Results:  
New Firefox windows are opened each time.

Expected Results:  
1. Use any build.
2. Tell FeedDemon to use default browser.
3. Click a link in FeedDemon.
4. Watch as the existing window is re-used. (DEFAULT/PROPER BEHAVIOUR)
Still evident on:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608
Firefox/0.8.0+

As before, I've tried a trunk build and a branch, and the problem is only on the
branch build.

The author of FeedDemon (Nick Bradbury) has confirmed this isn't a problem with
FeedDemon.
Whiteboard: DUPEME[DDE]
I've changed the summary, as I've just noticed that windows aren't being re-used
when using Outlook, Outlook Express etc, not just FeedDemon.
Summary: Multiple Windows are Opened when using FeedDemon → Multiple Windows are Opened from external programs
I'm seeing the same behavior; with 0.8 I used to get an email with 3-4 links in
it and click a link, go to firefox and ^-T to get a new tab, the click the 2nd
link in the email, etc.  That way I could open a bunch of links in a tabbed
browser window.

Now when I click a link in outlook, it opens TWO new Firefox windows, rather
than using the existing browser.  
Just confirmed this is still a problem with the latest (2004-06-19) build for
Win32 (XP).
Hello, i have same problem with FireFox 0.9 (XP and W98SE).

No problem with Firefox 0.8+ 20040605
I'm seeing this behaviour from outlook 2003 as well. When I click on a link in
an email, I have two Firefox windows open with the content from the link
location. I'm using the release build of 0.9. I had no problems of this nature
with 0.8.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

I just tested it in an older build of Thunderbird 0.6/20040502 and clicking on a
link exhibited the same behaviour as above - two windows opening.
(In reply to comment #6)
> I just tested it in an older build of Thunderbird 0.6/20040502 and clicking on a
> link exhibited the same behaviour as above - two windows opening.

I think you have a different problem.

The problem I am describing is the fact that Firefox is not re-using existing
windows, and opens a new window for every clicked link.
Changed to the summary to more accurately reflect the problem.

From: Multiple Windows are Opened from external programs
To: Firefox insists on opening a new window rather than reusing an existing window

I think this will help solve the confusion between this bug and bugs like BUG 246078

Sorry, I should have made this clearer in the beginning.
Summary: Multiple Windows are Opened from external programs → Firefox insists on opening a new window rather than reusing an existing window
My apologies. I have created a new bug for the behaviour I experienced. It can
be found at

http://bugzilla.mozilla.org/show_bug.cgi?id=248593
*** Bug 247324 has been marked as a duplicate of this bug. ***
(In reply to comment #10)
> *** Bug 247324 has been marked as a duplicate of this bug. ***

Still doesn't work correctly in 0.9.1 on Windows XP (Home or Pro).
Confirming that the release version of FF 0.9.1 is still knackered.

I've found that installing the Tabbrowser Preferences extension from
<http://www.pryan.org/mozilla/site/TheOneKEA/tabprefs/> and configuring it to
open external links in current tab restores the pre 0.9 behaviour. However, as
this requires the user to install an extension, this is only a workaround... not
a fix.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
The tabprefs plugin at least constrains the external links to tabs, but it's
still opening 2 tabs (vs. 2 windows without the extension).  External programs
appear to be sending the link TWICE; it either opens 2 windows or 2 tabs,
depending on the configuration.... still sub-optimal.  I'm about to go back to
0.8 it's getting so annoying.
(In reply to comment #13)
> The tabprefs plugin at least constrains the external links to tabs, but it's
> still opening 2 tabs (vs. 2 windows without the extension).  External programs
> appear to be sending the link TWICE; it either opens 2 windows or 2 tabs,
> depending on the configuration.... still sub-optimal.  I'm about to go back to
> 0.8 it's getting so annoying.

Rich, I think your problem is related more to BUG 246078 than this one.

Gavin Treadgold (see above), who was experiencing the same problem as you,
opened up BUG 248593 which was later marked as a dupe of BUG 246078.
I coasted in here after fixing the double-window open problem (Bug #246078) and
was mortified to find some in that discussion talking about this
never-reuse-windows behavior as a possible 'feature.'  If it is, the option to
turn it off is necessary for those of us using older machines with limited
resources.   While opening ten or twenty separate windows/tabs may not be a
problem with new machines, it's an invitation to crash the system when you're
running closer to the bone.
I found a bit of a workaround for this behavior:

The Tabbrowser Preferences extension (
http://www.pryan.org/mozilla/site/TheOneKEA/tabprefs/ ) allows you to control
the window-spawning behavior, and lets you force external links to open in the
current window.  I'd consider this a workaround more than a solution, mostly
because 

A) same-window usage is in significant demand (as is the new-window usage, thus
the need to be able to set it in the options), and 

B) many applications have context-menu options to open a link in a new or the
current window, which is completely lost by forcing new windows open every time

C) TBP forces the same window to be reused every time, even if you select "open
in new window," again negating the widespread functionality of many other
applications.
Jonathan Dagger, don't remove people from the CC list.
Flags: blocking-aviary1.0?
This will be fixed by bug 172962 shortly.

*** This bug has been marked as a duplicate of 172962 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Component: General → Tabbed Browser
Flags: blocking-aviary1.0?
QA Contact: firefox.general → firefox.tabbed-browser
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.