page depends on ID selectors beginning with numbers

RESOLVED INVALID

Status

defect
RESOLVED INVALID
15 years ago
4 years ago

People

(Reporter: michal-bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8a2) Gecko/20040606
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8a2) Gecko/20040606

When an IMG tag has only a 'width' specified, the 'height' is inherited from it
instead of using the value read from the image itself. 
E.g. GIF image with size 1x1 px. With <img src=... width=10> I expect the image
be rendered with 10 px width and 1 px height. BUT mozilla renders 10x10 instead.
Similar problem when only height is specified.

This is observed since cca ver 1.8a1 (IIRC 1.7 branch was fine).

Reproducible: Always
Steps to Reproduce:
1. See details or look at http://www.logix.cz/michal/dl/1x1.html

Actual Results:  
Wrong height of the image: size 10x10 px.

Expected Results:  
Image sized 10x1 px.
ok... http://www.w3.org/TR/html4/struct/objects.html#visual doesn't really say
anything about this case, and this behaviour is implemented in exactly the same
way across all current browsers. considering that, it seems like a bad idea to
change this.

this sounds like wontfix to me.
Component: Image: GFX → Layout: Images
QA Contact: core.layout.images
HTML isn't clear, and CSS is:
http://www.w3.org/TR/2004/CR-CSS21-20040225/visudet.html .

->invalid, per CSS
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → INVALID

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED
Reporter

Comment 4

15 years ago
Sorry, I have apparently extracted a bad testcase. The real example is here:

http://www.toplist.cz/stat.asp?menu=4096&kdy=dnes&n=64223

Try this URL in mozilla 1.8 and compare with mozilla 1.6 or konqueror. 
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

15 years ago
NN 4.8 renders images also as squares. Opera 7.51 and MSIE 6.0 render images as
author suppose, not as squares.

Pavel: Isn't this issue also for czech TechEvan?
OS: Linux → All
Whiteboard: parity-opera
The description in comment 0 is completely incorrect in explaining what the
problem is.  The real problem is the following:

The page in question specifies the height for the image using HTML attributes
and the 'width' using a CSS style rule.  (It has nothing to do with unspecified
width.)  The CSS style rule is on line 78 of http://www.toplist.cz/style.css ,
and looks like this:

.g .graph .c#4 IMG { width: 4px; }

CSS2.1 was recently clarified to say that ID selectors must be identifiers. 
This means that #4 is an invalid selector and the style rule must be ignored at
parse time.  Mozilla fixed this in bug 239079, so this bug report is invalid.
Assignee: jdunn → czech
Component: Layout: Images → Czech
Product: Browser → Tech Evangelism
QA Contact: core.layout.images → czech
Version: Trunk → unspecified
Summary: Images have wrong width/height. → page depends on ID selectors beginning with numbers
Whiteboard: parity-opera

Comment 7

15 years ago
Bug MOVED to our Bugzilla.
http://bugzilla.czilla.cz/show_bug.cgi?id=379

David, thanx for your explanation.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → INVALID

Comment 8

15 years ago
Toplist has fixed selector and page renders okay.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.