Improving New User Experience

VERIFIED DUPLICATE of bug 214523

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 214523
15 years ago
13 years ago

People

(Reporter: jh, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040508 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040508 Firefox/0.8.0+

There has been more than enough flaming on both sides of this issue - allow me
to offer a constructive (and what I hope to be valid) potential solution to this
whole debate.

Regardless of the visual merits of Qute vs. the new default theme, the key issue
on this seems to be a fear that the new theme will 'turn off' NEW users who may
not be aware of how to change a theme. This may be a valid point, and it is
equally valid that these same users may also not like Qute as a default (yes, it
is possible).

The solution - to my mind - is this (for the record, I am a marketing and PR
counsultant with nearly 20 years of expertise in trying to resolve issues just
like we're having right now):

Upon the first running of a *new* install of Firefox (or Tbird), via the default
installer (which is what a new user will use anyway, particularly on Windows and
Mac) on ANY operating system , the program should FOR THE FIRST INSTANCE ONLY OF
THE PROGRAM'S RUNNING, send the user to a default page which says *IN THE VERY
FIRST SENTENCES* someting akin to the following:

"On behalf of both the Developers and the Mozilla community, welcome to what
users and reviewers alike consider the finest Internet software available - as
you will shortly discover, Mozilla programs allow you, the user, an
unprecedented level of customization to the appearance and functionality of your
Internet experience. By way of example, if you would prefer to change the
appearance of this software - its 'look and feel' - click this link to see a
wide range of alternate user interfaces and extensions designed by others in the
community. Again, our thanks for your support of what is rapidly becoming a new
standard of excellence for browsing and email - the Mozilla solution."

The link should be to a jump page with options to go to the Texturizer or
Firefox/Tbird/Mozilla theme / extension page(s).

I believe this approach serves two functions - it THANKS the user for trying
this new software (always a good thing to appear 'kindler and gentler' than the
default solution you are seeking to replace) AND instantly shows them how to
change the theme IF and I say IF they don't like it - right when they first run
the software.

Again - let us try to focus on positive, constructive solutions to this issue!

I welcome any comments on this proposed solution - from both the
community-at-large and most especially Ben or other developers.

Many thanks for your time, consideration and lack of flaming if you don't agree
with this proposal - Jonathan

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
While, the exact text may be a bit too long for the average user, I think a
different start page would be quite a nice improvement for potienal converts. It
should probably talk about themes extensions and maybe some unique features to
firefox. Also it should have pictures demonstrating each.

Comment 2

15 years ago
The issue now is "if the new theme is going to fit?".
I don't see it fitting in any possible angle. the Qute theme is by far superior
than this new theme.
Lets hope for the miracle.

Comment 3

15 years ago
Kenny Lee (and anyone tempted to make similar posts): there has been plenty of
flaming about the theme change elsewhere. There is no place in this bug for
discussion of specific theme preferences.

Please restrict all discussion to the specific suggestion being made here.

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 214523 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Status: RESOLVED → VERIFIED

Updated

13 years ago
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.