If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

no error message when select attribute of xsl:copy-of is missing

RESOLVED WORKSFORME

Status

()

Core
XSLT
--
enhancement
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Biesinger, Assigned: peterv)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

transformiix does not show an error when I use xsl:copy-of without giving a
select attribute; it seems to apply a part of the transformation then.

xalan on the other hand tells me exactly what was wrong.

Comment 1

14 years ago
http://lxr.mozilla.org/seamonkey/source/extensions/transformiix/source/xslt/txStylesheetCompileHandlers.cpp#1669
looks like it should error. Could we get a testcase?
(In reply to comment #1)
> looks like it should error. Could we get a testcase?

ok, I'll attach a testcase shortly.

the testcase was "load the xml file with the xml-stylesheet in the browser"
(should've mentioned that...), should that error be visible there?
hmm... works now on this linux machine... (although with an unhelpful error
message, well I didn't really expect a good error from mozilla anyway)

I'll check again when I'm at a windows machine again (probably tomorrow)
huh. I absolutely can not reproduce this anymore. no idea what happened.

for reference:  I had seen this on winxp home 2004052307.

the error message I get now is "Error loading stylesheet: Parsing an XSLT
stylesheet failed."
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.