If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Typing a decimal comma with numeric keypad renders "|" instead of ","

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Björn, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040602 Firefox/0.8.0+
Build Identifier: Thunderbird; 0.6+ (20040608)  http://ftp24moz.newaol.com/pub/mozilla.org/thunderbird/nightly/latest-trunk/

The comma problem applies to any text field, including the compose window.


Reproducible: Always
Steps to Reproduce:
1. Enter numbers with the numerica keypad in any text field


Actual Results:  
To type 1/5 using the decimal comma renders 0|5

Expected Results:  
0,5

The normal keypad renders the comma correctly.
The problem with | instead of , does not exist in any other application, except
Firefox, where it has been reported: Bug 159733
(Swedish settings with Swedish keypad, Mandrake 10, KDE, 2.6.3-kernel)

Comment 1

14 years ago
Mozilla should use "," instead of "|" as separator char. This happens when
KP_Separator is pressed.

Please fix this now that you know the cause!
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 3

12 years ago
The bug does not appear in 1.6a1 so the problem seems solved (thanks!)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 4

12 years ago
We don't know what fixed this, worksforme.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 5

11 years ago
Resolving as per last comments and auto-resolve01
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago11 years ago
Resolution: --- → FIXED

Updated

10 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.