Convert Bugzilla footer to html4 and css (no functionality change)

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
User Interface
--
enhancement
RESOLVED FIXED
13 years ago
4 years ago

People

(Reporter: Svetlana Harisova, Assigned: Vitaly Harisov)

Tracking

unspecified
Bugzilla 2.18
Bug Flags:
approval +

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2) Opera 7.51  [en]
Build Identifier: 

We continue to improve bugzilla html/css code (see bug 240486).
This is corrected footer code.

These changes are tested with:

Mozilla 0.9.8  (Windows NT 5.2)
Mozilla 1.7.b  (Windows NT 5.2)

Opera 5.12 (Windows NT 5.2)
Opera 6.06 (Windows NT 5.2)
Opera 7.23 (Windows NT 5.2)
Opera 7.51 (Windows NT 5.2)

MSIE 4.0 (Windows NT 5.2)
MSIE 5.0 (Windows NT 5.2)
MSIE 5.5 (Windows NT 5.2)
MSIE 6.0 (Windows NT 5.2)

Netscape 4.78 (Windows NT 5.2)

Links 0.98 (Windows NT 5.2)
Lynx 2.8.2rel.1 (Windows NT 5.2)


Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Created attachment 150301 [details] [diff] [review]
corrected footer code
(Reporter)

Updated

13 years ago
Attachment #150301 - Flags: review?(myk)
Comment on attachment 150301 [details] [diff] [review]
corrected footer code

>diff -r -u css\global.css css\global.css

Nit: if possible, please use Unix-style path separators (i.e. / instead of \)
in patches.

Nit: if possible, please don't remove whitespace from the ends of lines (your
text editor may do this for you automatically), as it causes spurious conflicts
(although those can be resolved by directing patch to ignore whitespace
changes).

Otherwise the code looks good, but there's one style snafu: links and their
labels get vertically aligned along their bottom edges with the patch applied
instead of their baselines (f.e. "Actions:" is lined up with the underline for
the "New" link instead of the word "New" itself), which looks bad and should be
fixed.
Attachment #150301 - Flags: review?(myk) → review-
(Assignee)

Comment 3

13 years ago
Created attachment 151468 [details] [diff] [review]
corrected footer code (after review)
(Assignee)

Updated

13 years ago
Attachment #151468 - Flags: review?(myk)
Comment on attachment 151468 [details] [diff] [review]
corrected footer code (after review)

looks good, works; r=myk
Attachment #151468 - Flags: review?(myk) → review+
Low risk enhancement, sibling to bug 240486, worth getting into 2.18. a=myk and
checking in for user without checkin privileges.

(Vitaly and Svetlana: I've given you permission to edit bugs and file bugs into
the "new" state on this Bugzilla installation so your bugs no longer appear in
the "unconfirmed" state initially.)

Checking in css/global.css;
/cvsroot/mozilla/webtools/bugzilla/css/global.css,v  <--  global.css
new revision: 1.3; previous revision: 1.2
done
Checking in template/en/default/global/banner.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/banner.html.tmpl,v
 <--  banner.html.tmpl
new revision: 1.8; previous revision: 1.7
done
Checking in template/en/default/global/footer.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/footer.html.tmpl,v
 <--  footer.html.tmpl
new revision: 1.12; previous revision: 1.11
done
Checking in template/en/default/global/useful-links.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/useful-links.html.tmpl,v
 <--  useful-links.html.tmpl
new revision: 1.26; previous revision: 1.25
done
Checking in template/en/default/search/search-specific.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/search/search-specific.html.tmpl,v
 <--  search-specific.html.tmpl
new revision: 1.7; previous revision: 1.6
done
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Flags: approval+
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.18
(Reporter)

Comment 6

13 years ago
In previous patch we don't take into account that some users
will may want to style by css different group of links
in are different ways (e.g. actions-group will be green, 
edit-group will be yellow and saved-searches group will be
an other favorite color).

The our previous implementation of footer has made this impossible, 
because we assign ID not for all group=links+name_of_group but only for 
name_of_group:

<div class="group">
    <div id="link-edit">Edit:</div>
    <div class="links">
    	......
    </div>
</div>

The present CSS specification doesn't allow to access parent
properties from child rule.

We can assign ID for group=links+name_of_group, and when all
other users can design by CSS both whole group and
links or name_of_group with help of context selectors.

We have rewritten our previous patch from this point of view.
Now code looks like:

<div id="links-edit">
	<div class="label">Edit:</div>
    <div class="links">
    	......
    </div>
</div>

Sorry for your inconvenience.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
This bug already has code checked in, and what you're proposing is an additional
extension to the existing code, not a regression caused by this checkin.  Please
file a new bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

13 years ago
Created attachment 151551 [details] [diff] [review]
New patch which provides an ability to style different group of links in diffrent ways
Blocks: 253449
Assignee: myk → vitaly
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.