unable to submit some login forms

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
14 years ago
8 years ago

People

(Reporter: Drew D. Saur, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

Recent builds of Mac Firefox (0.9) are having problems submitting some login
forms that I frequently use, including the Amazon.com account login screens
(where pressing the "sign in using our secure server" button does nothing but
select it) and a credit union site I use
(https://www.cusa-hfs.com/hfs/svc/gateschilifcu/account/summary.jsp).

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040608
Firefox/0.8.0+

Confirmed on Windows with Firefox 0.9RC1. However, in my case it only applies to
<input type="image"> elements. To reproduce, try the login form, here:
http://www.okcupid.com/.

Comment 2

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040609
Firefox/0.8.0+
Using FF 0.9RC, my bank's page just stays at the "Please wait, confirming
account data" message if I try to log in. Same for eBay.
Url for my bank is
https://meine.deutsche-bank.de/mod/WebObjects/dbpbc.woa/33/wo/t3n2M6tbWMEfG2L6BqacUM/0.0.Login.0.13.3

Comment 3

14 years ago
*** Bug 246176 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
oops.. now I've found the right bug to dupe to.

*** This bug has been marked as a duplicate of 244698 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
OS: MacOS X → All
Hardware: Macintosh → All
Resolution: --- → DUPLICATE

Comment 5

14 years ago
reopening this bug as it's probably not the same issue
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

14 years ago
Confirming based on multiple reports.

Can people seeing this say whether they installed over previous versions of
Firefox? or are using old profiles? extensions?  Can anyone reproduce this with
a clean install and profile?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

14 years ago
In my case the bug occurs because I had copied signons.txt from my old Firefox
0.8 profile directory. The 0.9RC installer does not migrate this file, and so
you lose all your remembered passwords when upgrading.
(Reporter)

Comment 8

14 years ago
Lo and behold, yes it's the migrated signons.txt that causes the problem!

D

Comment 9

14 years ago
I guess that would mean this bug is invalid, seeing as you're supposed to use a
new profile...

Comment 10

14 years ago
I have remove the sigon.txt file from my profile, and now a i've not the bug, I
just have to remember all my password ;)

Updated

14 years ago
Summary: Recent builds of Mac Firefox (0.9) are having problems submitting some login forms → unable to submit some login forms

Comment 11

14 years ago
*** Bug 247465 has been marked as a duplicate of this bug. ***

Comment 12

14 years ago
Well, it is not Firefox related. Mozilla shows this symtoms, too.

The bug also appears on Google AdSense
https://www.google.com/adsense/?hl=de
and some other websites.

You try to login and nothing happens. You try again and again and after some
tries it works. The bug is not reproducable. Sometimes it works fine the first
time. When using the menu (e.g. you switch to reports or account informaton),
sometimes the login screen appears again and you have to login again.

I have tested it with 1.7 and 1.8a on several systems (Win 2000, Win XP).

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Component: General → Browser-General
Product: Firefox → Browser
Version: unspecified → Trunk

Updated

14 years ago
Assignee: firefox → general
QA Contact: firefox.general → general

Comment 13

14 years ago
*** Bug 246642 has been marked as a duplicate of this bug. ***

Comment 14

14 years ago
*** Bug 252559 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Comment 15

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 16

8 years ago
Stephan Slabihoud does not see this in firefox, so closing WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.