Autocomplete form doesn't work properly on sites with frames.

RESOLVED FIXED

Status

RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: rc, Assigned: mikepinkerton)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; it-it) AppleWebKit/125.2 (KHTML, like Gecko) Safari/125.8
Build Identifier: 

Mac OS 10.3.4
Camino 0.8b
Preferences - Privacy - autofill password forms checked.
Anytime I insert username and password the browser ask me if I want to store them in the Keychain, 
and it does what is asking for, but next time you navigate to that page it doesn,t fill the fields.
I try to uninstall everything and delete any preferences related, install everything again, but the problem 
persist.


Reproducible: Always
Steps to Reproduce:
1.
2.
3.


Expected Results:  
It should have placed in the fields the username and password stored in the keychain.

Comment 1

15 years ago
Are you making sure to wait until the pages are fully loaded? Name and password
aren't filled in until the page is completely done loading.

Also, are you seeing entries in the Keychain for the passwords you've stored?

Does this happen everywhere, or are there specific pages where it doesn't work?
(Assignee)

Comment 2

15 years ago
give me a url on which this happens.
(Reporter)

Comment 3

15 years ago
(In reply to comment #1)
> Are you making sure to wait until the pages are fully loaded? Name and password
> aren't filled in until the page is completely done loading.
> 
> Also, are you seeing entries in the Keychain for the passwords you've stored?
> 
> Does this happen everywhere, or are there specific pages where it doesn't work?

Thank you for getting back to my posted bug.
-Yes I am waiting until the page is fully loaded.
-Yes I am seeing in the Keychain all the entries included the ones that doesnn't work.
-No It doesn't happen everywhere, but most of the online banking pages won't work.
I.E.: 
- works for http://www.xelion.it/
- do not work for http://www.fineco.it, http://www.unicreditbanca.it/it/

Best regards, Roc

Comment 4

15 years ago
Looks like it may be another frame bug. On both broken pages, the login
information is not actually on that page, but on another page loaded in a frame.
 I'll try to make a reduced test case at some point and see if that's the problem.

Comment 5

14 years ago
Reporter could you please update this bug?

Comment 6

14 years ago
Confirming using 2004101408 (v0.8+) NB on 10.3.5.

I tested and this seems indeed an issue where autofill doesn't work on website
that have frames in which you need to login. This is bad bad bad.
Severity: major → blocker
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: autocomplete form doesn't work properly → Autocomplete form doesn't work properly on sites with frames.

Updated

14 years ago
Severity: blocker → normal
(Assignee)

Comment 7

14 years ago
i fixed this.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.