cant access java buttons(class) using mozilla behind microsoft isa proxy

RESOLVED DUPLICATE of bug 246028

Status

()

RESOLVED DUPLICATE of bug 246028
15 years ago
15 years ago

People

(Reporter: barroca, Assigned: darin.moz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.6) Gecko/20040122 Debian/1.6-1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.6) Gecko/20040122 Debian/1.6-1

When i try to access this brazilian bank site
https://www2.bancobrasil.com.br/aapf/aai/login.pbk to access my bank account via
web, the java buttons cannot be openned when i use mozilla behind my isa proxy
server.

Other sites can be viewed normally.

The error of the java console is:


Java(TM) Plug-in: version 1.5.0
Using JRE version 1.5.0-beta Java HotSpot(TM) Client VM
User home directory = /home/barroca
----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
o:   trigger logging
p:   reload proxy configuration
q:   hide console
r:   reload policy configuration
s:   dump system and deployment properties
t:   dump thread list
v:   dump thread stack
x:   clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------
java.io.IOException: Unable to tunnel through proxy. Proxy returns "HTTP/1.1 407
Proxy Authentication Required ( The ISA Server requires authorization to fulfill
the request. Access to the Web Proxy service is denied.  )"
	at sun.net.www.protocol.http.HttpURLConnection.doTunneling(Unknown Source)
	at
sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Unknown
Source)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(Unknown Source)
	at sun.plugin.net.protocol.http.HttpUtils.followRedirects(Unknown Source)
	at sun.plugin.cache.CachedJarLoader.isUpToDate(Unknown Source)
	at sun.plugin.cache.CachedJarLoader.loadFromCache(Unknown Source)
	at sun.plugin.cache.CachedJarLoader.load(Unknown Source)
	at sun.plugin.cache.JarCache.get(Unknown Source)
	at sun.plugin.net.protocol.jar.CachedJarURLConnection.connect(Unknown Source)
	at sun.plugin.net.protocol.jar.CachedJarURLConnection.getJarFile(Unknown Source)
	at sun.misc.URLClassPath$JarLoader.getJarFile(Unknown Source)
	at sun.misc.URLClassPath$JarLoader.<init>(Unknown Source)
	at sun.misc.URLClassPath+3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at sun.misc.URLClassPath.getLoader(Unknown Source)
	at sun.misc.URLClassPath.getLoader(Unknown Source)
	at sun.misc.URLClassPath.getResource(Unknown Source)
	at java.net.URLClassLoader+1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at sun.applet.AppletClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.applet.AppletClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.applet.AppletClassLoader.loadCode(Unknown Source)
	at sun.applet.AppletPanel.createApplet(Unknown Source)
	at sun.plugin.AppletViewer.createApplet(Unknown Source)
	at sun.applet.AppletPanel.runLoader(Unknown Source)
	at sun.applet.AppletPanel.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
load: class br/com/bb/aapf/bbteclado/CampoTeclado.class not found.
java.lang.ClassNotFoundException: br.com.bb.aapf.bbteclado.CampoTeclado.class
	at sun.applet.AppletClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.applet.AppletClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.applet.AppletClassLoader.loadCode(Unknown Source)
	at sun.applet.AppletPanel.createApplet(Unknown Source)
	at sun.plugin.AppletViewer.createApplet(Unknown Source)
	at sun.applet.AppletPanel.runLoader(Unknown Source)
	at sun.applet.AppletPanel.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: open HTTP connection failed.
	at sun.applet.AppletClassLoader.getBytes(Unknown Source)
	at sun.applet.AppletClassLoader.access+100(Unknown Source)
	at sun.applet.AppletClassLoader+1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	... 10 more




when i install the python porxy http://apserver.sourceforge.net/ and poit
mozilla to it, the java console is oppend ok.

Reproducible: Always
Steps to Reproduce:
1.install debian unstable with mozilla 1.6
2.install jre 1.5.0 from sun site
3.link the plugins to mozilla plugins, so that java can be used by mozilla
4.click edit preferences advanced proxies and chose automatic configuration,
point it to tha microsoft isa server
5. enter the bank address and a window will be open so that you can authenticate
to the isa proxy server (this window is openned for every web site)


Actual Results:  
mozilla can't open the java buttons of the page. as described in details

Expected Results:  
well, mozilla in windows, with the same java installed, and using microsoft ISA
server of proxy, is doing this job ok, opennig the java buttons, so the expected
results in linux is the same of windows.

when i install the python porxy http://apserver.sourceforge.net/ and poit
mozilla to it, the java buttons is oppend ok.

if there is any doubt with language (because the site is in portuguese) send me
an email..

a tcpdump will be helpfull?
(Reporter)

Updated

15 years ago
Summary: cant access java console using mozilla behind microsoft isa proxy → cant access java buttons(class) using mozilla behind microsoft isa proxy

*** This bug has been marked as a duplicate of 246028 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.