New tab menu options: Copy tab/all tabs to new window

RESOLVED WONTFIX

Status

SeaMonkey
Tabbed Browser
--
enhancement
RESOLVED WONTFIX
14 years ago
8 years ago

People

(Reporter: Lloyd Wood, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Right-clicking on a tab produces a menu for tab management (Close Tab, Close
Other Tabs, etc.) This menu would benefit from several new options:

1. Copy Tab to New Window.
This copies the current tab contents to a new browser window, allowing
subsequent related tabs that are opened from that tab to be grouped together in
a per-window basis, rather than opening new tabs from various existing tabs all
mixed together in the same window.

2. Copy All Tabs to New Window.
Because you want to use this set of tabs as a starting point, but go in
different directions in different windows.

(Okay, you could achieve 1. by doing 2. then Close Other Tabs - but there's
already some redundancy in the menu, and the 'do with this tab'/'do with all
tabs' convention is pretty strong.)

Comment 1

14 years ago
This sounds like bug 102132, essentially.

Comment 2

14 years ago
In 102132 the focus seems to be move, while here the request is copy.
Product: Core → SeaMonkey

Comment 3

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 4

8 years ago
This new options would make the user interface to complicated. Copying tabs can be done with Drag & Drop. WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.