<window> XUL mantain width and height.

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: faser, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

772 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Firefox 0.9 RC

Opening a new window with XUL, the child window doesn't mantain width and height.
The child window is open in fullscreen instead of using the widht and height
properties.
It works in Firefox 0.8

Reproducible: Always
Steps to Reproduce:
OPENER WINDOW
<?xml version="1.0" encoding="UTF-8"?>
<window id="parent" 
	title="Parent"
	xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">
<hbox>
<button label="Open New Window"
oncommand="window.open('child.xul','Child','chrome,centerscreen,modal');"/>
</hbox>	
</window>

<?xml version="1.0" encoding="UTF-8"?>
<window id="child" 
	title="Child"
	width="300"
	height="300"
	xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">
<label value="Child Window"/>
</window>	

Actual Results:  
The new window is opened wider than expected

Expected Results:  
The window should be opened with with 300 and height 300
This bug was last touched before 1.0.4. Is it still reproducable?
Try the latest branch build (1.0.5): http://www.mozilla.org/products/firefox/
Try the latest nightly trunk build (v1.0+): http://www.mozilla.org/developer
(Reviving old UNCONFs)

Comment 2

13 years ago
Created attachment 199709 [details]
testcase

Comment 3

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051015
Firefox/1.4.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 4

13 years ago
I don't know why Nickolay Ponomarev marked this bug as "RESOLVED" because it
still does not work correctly in Mozilla 1.5 Beta 2. The child window opens full
screen when it should be only 300x300.

Comment 5

13 years ago
Scott: the attached testcase works fine for me, when opening from Extension
Developer Extension's  XUL editor, that is from priviledged location.

If you test right from bugzilla, i.e. unpriviledged page (which isn't mentioned
anywhere in the bug btw!), it will indeed open fullscreen, or rather the same
size as the parent window.

This is because the 'chrome' option is ignored for non-privileged content since
0.9. The window.open call opens a browser window, which is of course shouldn't
be affected by width attribute on the content <window> element. If the bug was
about this issue, it's invalid.
You need to log in before you can comment on or make changes to this bug.