pre-0.9 extensions are not listed in extensions and cannot be uninstalled

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED WONTFIX
14 years ago
10 years ago

People

(Reporter: Andy Lutomirski, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

When pre-0.9 extensions are installed, they don't show up in the extension
manager.  This means that they can't be uninstalled.

Some examples: aasted.org/adblock/viewtopic.php?t=457
http://needlesearch.mozdev.org/

This also makes it impossible to get to the configuration options for that
extension.

This problem makes most existing extensions nearly useless.

Reproducible: Always
Steps to Reproduce:
1. Install one of the above extensions
2. Try to uninstall it.

Actual Results:  
Nothing, since there's no UI to uninstall it.

Expected Results:  
It should have been listed in Extensions, or the install should have failed.

Comment 1

14 years ago
There is an extension called show old extensions - get it from the mozillazine
forums http://forums.mozillazine.org/viewtopic.php?t=81790
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)

This, or something like it, really ought to be added.  It would be unfortunate
if 1.0 were released when extensions for "Firefox" mostly worked but couldn't be
configured or disabled.

Comment 3

14 years ago
By the time 1.0 comes around in a few months nearly all extensions should be
re-packaged (either by their original authors or by someone else). Showing
pre-0.9 extensions now would only reduce the incentive to re-package and thus
slow down the rate at which it happens (and until they are re-packaged, you
can't uninstall or automatically update them).

Comment 4

14 years ago
But please inform people about this extension for backward compatibility with
pre-0.9 extensions, at least at 0.9 official release.

Comment 5

14 years ago
I have MozCC, jslib, and ChatZilla extensions installed on 0.8

when 0.9 was successfully installed it did not pick up these extensions.

within preferences, I can't see an 'extensions' icon, so it isn't clear to me
whether or how to install these. 

From reading previous comments I guess someone will be asking the maintainers to
repackage these extensions. does seem like a lot of work and duplication of effort.
hope it's in a worthwhile cause.

Comment 6

14 years ago
When 0.9 is installed, it disables all old extensions and themes on purpose.  It
even notifies you of this.  Either get the SOE extension, or install FX 0.9
compatible versions.  Ben did this on purpose.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.