Crash in nsGfxScrollFrameInner::GetIntegerAttribute

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: roc)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

AVIARY branch builds are crashing when switching themes in
nsGfxScrollFrameInner::GetIntegerAttribute line 1759 (null parameter |aBox|).

Steps to reproduce:

1) Remove ~/Library/Application Support/Firefox or rename it to something else. 
2) Start Firefox (branch build)
3) Open http://bugzilla.mozilla.org/show_bug.cgi?id=245875 in the browser
4) Copy this URL http://members.shaw.ca/lucx/charamel-browser-104-experimental.jar
5) Open a new tab and navigate to http://texturizer.net/firefox/themes/#install
6) Paste the URL into the "Remote URL" box and click "Install" 
7) Click "OK" when prompted to install the theme. 
8) The Themes window will appear and the theme will be downloaded. Double click
on the theme. 

The app will crash at the location mentioned above, apparently trying to reflow
combo boxes (combo box frame methods are further up the stack) on the bugzilla
page opened in the background tab. The app *does not* crash if the bugzilla page
is not open. The talkback id for this crash is 82503.
I'm actually going to recommend reproducing this by pulling a FIREFOX_0_9_RC1
tag since I've checked in a band-aid to the AVIARY branch to stop the crash for
the 0.9 release. When I land EM etc on the trunk next week I will NOT check in
the band aid so you may be able to reproduce the crash there too. 
Created attachment 151078 [details] [diff] [review]
fix?

I don't have an Aviary build environment. Can you try this patch? It's a bit
wallpapery but I think it addresses the problem in the right way.
Assignee: nobody → roc
Status: NEW → ASSIGNED
I'll test this out this coming week.
I doubt this is still relevant, esp. since this method no longer exists.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.