Problems when quitting Mozilla while installing (from progress bar).

VERIFIED DUPLICATE of bug 24463

Status

Core Graveyard
Installer: XPInstall Engine
P3
normal
VERIFIED DUPLICATE of bug 24463
18 years ago
2 years ago

People

(Reporter: David Epstein, Assigned: Peter Trudelle)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
1. Go to XPInstall test page http://jimbob/trigger2.html.
2. In URL field, enter http://jimbob/jars/manyfiles.jar
3. Press Trigger button.
4. OK confirmation dialog.
5. Do one of these (doesn't matter when you do it, during download or 
finishing install):
a) Press close checkbox
b) Quit (from File menu)
c) Close (from File menu)
d) Windows only: right mouse click on task bar and select close
Results:
a) checkbox ==> 
* Win and Linux: Progress dlog remains on the screen, Mozilla quits. Logfile 
entry and files are installed. On Linux, progress dlog goes blank!
* Mac: Main window closes, but Mozilla doesn't quit. Menus go flaky (missing 
menu entries like under Bookmarks, Search and Go). After install completes, 
menus refresh, so this is only temporary insanity!
b) quit ==>
* Win and Linux: Progress dlog closes and Mozilla quits. No logfile entry, but 
partial file install (up to the # when quit occurred).
* Mac: Same as Win and Linux, but only if browser window is active. Otherwise, 
it won't quit.
c) close ==> same behavior as checkbox. Again, for Mac, browser window must be 
active.
d) task bar close ==> same as checkbox close.
Expected: Install should finish. Progress bar remains open and Mozilla does NOT 
quit until install is finished. Perhaps an error msg when user attempts to close 
or quit?

Comment 1

18 years ago
Don, this is another bug similar to 24463
Assignee: cathleen → dbragg
Target Milestone: M14

Updated

18 years ago
Depends on: 24463

Comment 2

18 years ago
this is a possilbe dup of 24463.  a bit different behavior.
Assignee: dbragg → trudelle
(Assignee)

Comment 3

18 years ago
sounds like the same problem to me, resolving, Daniel can reopen if necessary


*** This bug has been marked as a duplicate of 24463 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
VERIFY dupe
Status: RESOLVED → VERIFIED

Updated

10 years ago
No longer depends on: 24463
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.