Indicator/dialog for blocked XPIs

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
VERIFIED WORKSFORME
14 years ago
6 years ago

People

(Reporter: cilias, Unassigned)

Tracking

Trunk
x86
Windows XP
Dependency tree / graph
Bug Flags:
blocking-aviary1.0 -
blocking1.8b -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
With bug 240552 in effect, the there is no real indicator to tell users that an
XPI has been blocked. To quote bug 240552 comment 56:
"So now when someone clicks on, say,
http://www.hacksrus.com/~ginda/chatzilla/xpi/chatzilla-0.9.64.xpi then the
throbber will briefly spin and... that's all folks."

Without knowing about bug 240552, I first thought it was a slow connection, then
thought the XPInstall engine was broken. If all 1.7 is going to have concerning
bug 240552 is couple of prefs in about:config, there should be some sort of
indicator.
Such an indicator was intended to be part of the UI in bug 241705

*** This bug has been marked as a duplicate of 241705 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
I'm under the impression that bug 241705 is long term (and assigned to Firefox).
If this makes it into 1.7 final (and Netscape 7.2) without any UI, I think users
are going to be confused when a XPI is blocked.

Will a new larger whitelist be the answer?
Fair enough, this is a well-defined subset of bug 241705 that could be
implemented independently.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: xpi-engine → dveditz
Blocks: 241705
Status: REOPENED → NEW
(Reporter)

Comment 4

14 years ago
I should also add that a simple "Alert" message, with an OK button will do.
Something like the alert, when a user enters a URL that cannot be found. The
cool UI stuff, like an icon in the bottom corner, can come later in bug 241705.
(Reporter)

Comment 5

14 years ago
This bug was originally intended for Mozilla 1.7.
Now that Mozilla 1.7 has been released, with xpinstall.whitelist.required set to
false, this bug does not apply.

However, as Daniel Veditz states in comment 3, this bug works as a subset of bug
241705.

Updated

14 years ago
Flags: blocking-aviary1.0RC1?
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0RC1?
Flags: blocking-aviary1.0RC1-
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0-
(In reply to comment #3)
> Fair enough, this is a well-defined subset of bug 241705 that could be
> implemented independently.

It would be nice if we could land bug 270443 and bug 270170 early enough before
1.8b to use both of them to fix this bug.
Flags: blocking1.8b?

Updated

14 years ago
Flags: blocking1.8b?
Flags: blocking1.8b-
Flags: blocking-aviary1.0PR-

Updated

13 years ago
Flags: blocking1.8b4?
Flags: blocking1.8b3?

Comment 7

13 years ago
This is seamonkey-only, does not block aviary releases.
Assignee: dveditz → guifeatures
Component: Installer: XPInstall Engine → XP Apps: GUI Features
Flags: blocking1.8b4?
Flags: blocking1.8b3?
Product: Core → Mozilla Application Suite
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: guifeatures

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design

Comment 9

6 years ago
We now have notification boxes and doorhangers.
Status: NEW → RESOLVED
Last Resolved: 14 years ago6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

6 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.