Closed Bug 246136 Opened 18 years ago Closed 18 years ago

Closing a tab causes the remaining tab to carry the URL of the closed tab

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 227826

People

(Reporter: darnell, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+ (FireFox 0.9 RC 1)

When multiple tabs are opened via typing the URL(s) into the location bar and
pressing "CONTROL + ENTER" to open the URL(s) in a new tab, any tab closed
results in the remaining tab having the URL of the closed tab in the location bar.

Reproducible: Always
Steps to Reproduce:
1. Open Firefox 0.9 RC 1 with a web page as the default home page.  Any web page.
2. Type "www.netscape.com" into the location bar.
3. Press "Control + Enter" to open the URL in a new tab.
4. Close the tab using the close tab button on the right side of the browser tab
area.
5. The remaining tab will not have the correct URL.  It will have the URL of the
closed tab.

Actual Results:  
The location bar has the URL of the closed tab.

Expected Results:  
Should have the URL of the current active tab.
Ctrl + Enter does not open the URL in a new tab for me.. how can I set this up?
using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Correction, where I have mentioned "CNTRL + Enter" I should have said "ALT +
Enter".  I was confusing Firefox's command for new tabs with Mozilla's.
In addition, I'm also finding that when I type a new URL into the location bar
and hit "ALT + ENTER" to open it in a new tab, if I go to the first tab it has
the URL of the newest tab in the location bar.  No need to close any tabs.
I've still got the same issue with the latest 0.9 release.
Bug still exists in 0.9.1.
Confirming.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040628
Firefox/0.8.0+
dupe of bug 227826, isn't it?
(In reply to comment #7)
> dupe of bug 227826, isn't it?

Yes, I also think it is.

*** This bug has been marked as a duplicate of 227826 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Bug is Firefox only -> Firefox
Component: Tabbed Browser → Toolbars
Product: Browser → Firefox
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.