Left clicking on link to download file opens a new window

RESOLVED DUPLICATE of bug 102380

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 102380
14 years ago
9 years ago

People

(Reporter: u88484, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040609 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040609 Firefox/0.8.0+

When I left click to download a file, a new blank window also opens

Reproducible: Always
Steps to Reproduce:
1. Left click on link for a file


Actual Results:  
Opens a new window along with the "save dialog box"

Expected Results:  
Just display the "save dialog box"

Fresh install of firefox and profile, no extensions.

Comment 1

14 years ago
Can you give us detailed steps to reproduce?
(Reporter)

Comment 2

14 years ago
This only happens on some webpagesm for example:
http://www.ati.com/support/drivers/winxp/radeonwdm-xp.html?type=xp&prodType=graphic&prod=productsXPdriver&submit.x=11&submit.y=5&submit=GO%21
Left click on any of the 4 download links on the ATI page opens a new window,
but when left click on a download link say on
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/0.8/ no new window pops
up, and its not because its an FTP because also works on other pages.

Comment 3

14 years ago
The ATI page uses target="_blank" for those links, and Firefox doesn't know that
the window will result in a download, so it has to open a new window.  IE also
opens a window, but it's smart and closes the window as soon as it realizes that
the window existed only to initiate a download.

*** This bug has been marked as a duplicate of 102380 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
Actually the window does not close it stays open

Comment 5

14 years ago
Kurt: right.  Internet Explorer closes the extra window, but Firefox doesn't. 
Bug 102380 is about fixing that.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.