Subject/To/CC/BCC editbox: small delay before caret appears

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: steven, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: version 0.6 (20040502)

In the message compose window, when you focus any of the boxes in the
Subject/To/CC/BCC line, the caret takes a short while to appear. I believe this
is because it starts out in the 'invisible' state in its blinking pattern,
because the delay is about the same as the blinking period.

To improve visual feedback, the caret should be visible immediately. This is
especially important when you use tab to focus the field, because the visual
feedback is important there.

Note the difference with the main message body editor, where the caret shows up
immediately when you click.


Reproducible: Always
Steps to Reproduce:
1. Open a message composition window
2. Focus the To or Subject editboxes with the mouse or with tab


Actual Results:  
There is a small delay before the caret appears.

Expected Results:  
The caret should appear immediately after focusing.

Comment 1

13 years ago
WFM version 1.0+ (20050711) and no reply from reporter
marking WFM
If still a problem, please reopen with new information based on current TB version 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.