add support for Behavioral Extensions to CSS (behavior:)

RESOLVED DUPLICATE of bug 194205

Status

--
enhancement
RESOLVED DUPLICATE of bug 194205
15 years ago
14 years ago

People

(Reporter: CaptainN, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

This is a request that the W3C Behavioral Extensions to CSS (working draft) be
implemented in Mozilla (maybe as -moz-behavior: to start with).

Here is the link to the draft:
http://www.w3.org/TR/1999/WD-becss-19990804

Here is an example of it being used (an why it's so cool):
http://dean.edwards.name/moz-behaviors/src/

Here is the website of the trick that the above url uses to get behavior css
working in Mozilla:
http://dean.edwards.name/my/behaviors/


Since there is already a method (a pretty simple method really) to get behaviors
working in Mozilla, it shouldn't be difficult to get this feature implemented
(forgive me if I'm mistating the facts :-) ).

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
Sorry, I added the wrong address as the website for the trick to get behaviors
working in Mozilla. The correct address is here:
http://dean.edwards.name/moz-behaviors/

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 194205 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.