The default bug view has changed. See this FAQ.

Download manager sometimes fail to close when saving cached image

VERIFIED DUPLICATE of bug 243324

Status

()

Toolkit
Downloads API
--
major
VERIFIED DUPLICATE of bug 243324
13 years ago
7 years ago

People

(Reporter: Ng Ming Hong, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

After saving an image on that website, the download manager doesn't close. I
used the default setting for download manager (i.e. open download manager when
downloading, and close download manager when finished all downloads).

If I save the image the second time, the download manager closes correctly.
(i.e. for each images, the download manager fails to close when save it the
first time)

Reproducible: Always
Steps to Reproduce:
1. Open a website
2. Save an image
3. Save it again

Actual Results:  
Download manager fails to close on the first time.
It closes on the second time.

Expected Results:  
Download manager should close everytime it finishes downloading.

I'm using Firefox 0.9 RC.
(Reporter)

Comment 1

13 years ago
I know this bug sounds similar to bug 243324, but the file I downloaded is
149KB, much larger than ~30KB as mentioned in that bug report.
(Reporter)

Comment 2

13 years ago
Also, if I save a very small file (~3KB) not yet downloaded using "Save Link
as", the download manager always close.

Comment 3

13 years ago
Also seen on Linux (RH 9) with Firefox 0.9. Didn't occur in Firefox 0.8.

Problem occurs both when saving an image from a page and when saving an entire
cached page (<ctrl>-S).

Download manager appears during first save from cache. Disappears during second
(doesn't have to be the same image or page for me).

Comment 4

13 years ago
Using Firefox 0.9, I don't get the download manager at all when saving an image
from the page. Can you reconfirm this problem in Firefox 0.9 using a clean profile?

Comment 5

13 years ago
Yes - still occurs with a clean profile. FWIW, when I installed 0.9 I used the
installer, specified a custom install and selected only "developer tools" (over
and above base Firefox).

Comment 6

13 years ago
Also seen on Mac OS X, using Firefox 0.9.1
I've experienced this problem as well with Firefox 0.9.2.  

I don't think it's limited to cached files either since sometimes it occurs with
non-cached files.

This is my experience:

You can download a file/image/whatever and the Download will sometimes open up
and remain open after the file has been saved even though the option to close
the Download manager has been selected.

Downloading another completely different file/image/whatever will cause the
manager to close after the download is complete.
See bug 243324 comment 5

*** This bug has been marked as a duplicate of 243324 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Verifying old and obvious dupes. Sorry for bugspam.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.