If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash under high CPU load [@ js_LookupProperty() ]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Chris Applegate, Unassigned)

Tracking

({crash})

Other Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
User-Agent:       Opera/7.23 (X11; Linux i686; U)  [en]
Build Identifier: version 0.6+ (20040604)

While running Opera, Timidity++, BitTorrentGUI, and Thunderbird, I checked my 
mail and Thunderbird crashed. I am using Mandrake Official 10.0 and KDE 3.2. 
Thunderbird was installed by unzipping a binary package and dropping it in 
/usr/local, and launched via the executable 'thunderbird.' The applications 
running pretty much max out my CPU.

Reproducible: Sometimes
Steps to Reproduce:
1. Launch Thunderbird. 
2. Max out CPU.
3. Interact with Thunderbird.

Actual Results:  
It crashed.

Expected Results:  
Shouldn't have crashed.

See TB84417Q

See also <a href="show_bug.cgi?id=246170">Bug 246170</a> -- very similar 
circumstances surrounding several crashes in Firefox.

Comment 1

13 years ago
TB84417Q:
libmozjs.so + 0x510e8 (0x400690e8)
libmozjs.so + 0x2b46c (0x4004346c)
libmozjs.so + 0x2e7d2 (0x400467d2)
libmozjs.so + 0x2fd97 (0x40047d97)
libmozjs.so + 0x2d4c7 (0x400454c7)
libmozjs.so + 0x2e99f (0x4004699f)
libmozjs.so + 0x2e477 (0x40046477)
libmozjs.so + 0x2e99f (0x4004699f)
libmozjs.so + 0x2e477 (0x40046477)
libmozjs.so + 0x2e99f (0x4004699f)
libmozjs.so + 0x5aa06 (0x40072a06)
libmozjs.so + 0x59db8 (0x40071db8)
libmozjs.so + 0x59fde (0x40071fde)
libmozjs.so + 0x15506 (0x4002d506)
libgklayout.so + 0x37840b (0x4139540b)
libgklayout.so + 0x33e348 (0x4135b348)
libgklayout.so + 0x33b1f7 (0x413581f7)
libgklayout.so + 0x231e39 (0x4124ee39)
libgklayout.so + 0x232319 (0x4124f319)
libgklayout.so + 0x3d0c1b (0x413edc1b)
libgklayout.so + 0xb88b7 (0x410d58b7)
libgklayout.so + 0xb8783 (0x410d5783)
libgklayout.so + 0x23a434 (0x41257434)
libgklayout.so + 0x2386a7 (0x412556a7)
libgklayout.so + 0xb89b1 (0x410d59b1)
libgklayout.so + 0xb8171 (0x410d5171)
libgklayout.so + 0x370605 (0x4138d605)
libgklayout.so + 0x36f9d6 (0x4138c9d6)
libgklayout.so + 0x368746 (0x41385746)
libwidget_gtk2.so + 0x14276 (0x40f7f276)
libwidget_gtk2.so + 0xbe22 (0x40f76e22)
libwidget_gtk2.so + 0x1041e (0x40f7b41e)

Chris: Could you still reproduce with Thunderbird 0.7.x? Do you have another
TalkBack incident ID?
Keywords: crash
Summary: Crash under high CPU load → Crash under high CPU load [@ libmozjs.so ]
(Reporter)

Comment 2

13 years ago
Here's what I've got from 0.7:
TB186014X
TB181030Y
TB172715Q
TB166758K

Comment 3

13 years ago
All stacktrace look same:
js_LookupProperty()
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsobj.c,
line 2369]
LookupArgOrVar() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsemit.c,
line 1587]
EmitPropOp() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsemit.c,
line 1804]
js_EmitTree() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsemit.c,
line 4187]
js_EmitTree() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsemit.c,
line 3970]
js_EmitTree() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsemit.c,
line 3424]
js_EmitTree() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsemit.c,
line 3490]
js_EmitTree() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsemit.c,
line 2702]
js_EmitTree() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsemit.c,
line 3490]
js_EmitTree() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsemit.c,
line 2702]
Statements() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsparse.c,
line 1882]
FunctionBody() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsparse.c,
line 635]
js_CompileFunctionBody() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsparse.c,
line 687]
JS_CompileUCFunctionForPrincipals() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsapi.c,
line 3362]
nsJSContext::CompileEventHandler() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 65]
nsXBLPrototypeHandler::ExecuteHandler() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/content/xbl/src/nsXBLPrototypeHandler.cpp,
line 65]
nsXBLEventHandler::HandleEvent() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/content/xbl/src/nsXBLEventHandler.cpp,
line 84]
nsEventListenerManager::HandleEventSubType() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 710]
nsEventListenerManager::HandleEvent() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1525]
nsXULElement::HandleDOMEvent() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2841]
PresShell::HandleEventInternal() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6035]
PresShell::HandleEvent() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 5928]
nsViewManager::HandleEvent() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/view/src/nsViewManager.cpp,
line 710]
nsViewManager::DispatchEvent() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/view/src/nsViewManager.cpp,
line 96]
HandleEvent() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/view/src/nsView.cpp,
line 79]
nsCommonWidget::DispatchEvent() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/widget/src/gtk2/nsCommonWidget.cpp,
line 215]
nsWindow::OnButtonPressEvent() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/widget/src/gtk2/nsWindow.cpp,
line 1415]
button_press_event_cb() 
[/builds/cltbld/tinderbox/Thunderbird-0.7/Linux_2.4.20-28.8_Clobber/mozilla/widget/src/gtk2/nsWindow.cpp,
line 3264]

-> JavaScript land ?

Stacktrace is same as stack of bug 246170.
Assignee: mscott → general
Component: General → JavaScript Engine
Product: Thunderbird → Browser
QA Contact: pschwartau
Summary: Crash under high CPU load [@ libmozjs.so ] → Crash under high CPU load [@ js_LookupProperty() ]
Version: unspecified → Other Branch
(Reporter)

Comment 4

13 years ago
I've got a new CPU and haven't had any crashes yet, so I think the fault was in
my hardware. Should this be closed (INV/WFM), or is there a real bug somewhere
in all that stack trace?

Comment 5

13 years ago
Chris, lets mark it works for me for now. If you can reproduce the same behavior
with newer builds, please file a new bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
QA Contact: pschwartau → moz
Resolution: --- → WORKSFORME
Crash Signature: [@ js_LookupProperty() ]
You need to log in before you can comment on or make changes to this bug.