links not shown over td background images

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: marekj1, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows 2000
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a1) Gecko/20040520
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a1) Gecko/20040520

the page: http://www.biblioteka.elk.pl/
looks unusable in mozilla 1.8a1, but looks fine 1.6 probably other.
The main image should be on the left, there should be links on the right in 1.8a1
I think it's a problem with gecko, but wasn't sure if to file it under CSS or
Layout.
Maybe the severity should be raised above normal because it makes user think
that there's less info on the page than there actually is.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
can you attach a screenshot ? This page renders identical in IE6 and FF 20040602
on Win2k.
(Reporter)

Comment 2

15 years ago
mozilla 1.8a1 screenshot: http://www.castlesofpoland.com/moz2.jpg
in firefox 20040206 it also looks bad
this is mozilla 1.6 Gecko/20040117 http://www.castlesofpoland.com/moz3.jpg
1.6 is on linux, but it looks the same on windows.

and this one is the same page on ff 0.9 rc Gecko/20040608:
http://www.castlesofpoland.com/moz4.jpg 
this is totally wrong.
(Reporter)

Comment 3

15 years ago
just to confirm: 
in ff 0.9 rc Gecko/20040608 I have "Load images" option checked, and "load
images from this server only" (or sth like that) unchecked. so this looks like a
separate bug.

Comment 4

15 years ago
See this in FF 0.9rc and 1.8a1.  But if you save the files locally, then open
them they are fine.  The same is true in the Moz Editor - the links appear.

Comment 5

15 years ago
Okay, the links are in a table (the whole page) in a table (for the row) in a
table(for the links).  Is this the problem - do we see this with other nested
tables?  The bug decription could do to be altered - Marek, how about:

[www.biblioteka.elk.pl] Links not rendered correctly (nested tables)

(Reporter)

Comment 6

15 years ago
fine by my, but I think the problem is with tables not the links. also I thought
it would be helpful if the subject described that something's gone wrong between
1.6 and 1.8

Comment 7

15 years ago
This works fine for me in Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US;
rv:1.8a2) Gecko/20040608 Firefox/0.8.0+

This means we probably need to figure out when/where the bug was fixed and make
sure the fix gets into the branch(es).
(Reporter)

Comment 8

15 years ago
Aaron: which version do you see exactly? I tested the exacy same firefox and it
didn't display well, and on top of it it didn't display any images from that
website. (I installed it today over an older version)

Comment 9

15 years ago
My render in Camino 2004051715 (v0.8b) looks like Moz2 (id est, correct).

Comment 10

15 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040608

So seems to be a problem of 1.8a, (didn´t yet check)

Comment 11

15 years ago
(In reply to comment #9)
> My render in Camino 2004051715 (v0.8b) looks like Moz2 (id est, correct).

That should be moz3; a correct render.
(Reporter)

Comment 12

15 years ago
just make it clear:
the correct look of the website is: http://www.castlesofpoland.com/moz3.jpg

all other are incorrect.

Comment 13

15 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a2) Gecko/20040610

working BuildID 2004060809, regressed BuildID 2004060908

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyAll&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=20040608+08%3A00&maxdate=20040609+11%3A00&cvsroot=%2Fcvsroot

There was one bug, which fixed some table bugs, but it was also checked in to
the 1.7 branch, and I don´t see this bug here in 1.7

Bug 241161	  	[quirks] empty TABLE should hide
Keywords: regression
Summary: page looks unusable in 1.8a1, but looks fine in 1.6 → page looks unusable in 1.8a1 BuildID 2006060908 and later

Comment 14

15 years ago
Created attachment 150541 [details]
small testcase

Comment 15

15 years ago
confirming based on testcase, regressed BuildID 2004060908, see comment 13
Assignee: general → nobody
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout: Tables
Ever confirmed: true
Keywords: testcase
QA Contact: general → core.layout.tables
Summary: page looks unusable in 1.8a1 BuildID 2006060908 and later → page looks unusable in 1.8a1 BuildID 2004060908 and later

Comment 16

15 years ago
Created attachment 150545 [details]
minimal testcase

an empty <td> doesn´t show a background:
<TABLE WIDTH="600" BORDER="2"><TR><TD HEIGHT="10" STYLE="background:
#8AB7DE"></TD></TR></TABLE>

Updated

15 years ago
Attachment #150541 - Attachment is obsolete: true

Comment 17

15 years ago
the url looks fine with win 2004060908 1.8a2 on reload, but not on first load or
super reload

Comment 18

15 years ago
I think that comment # 13 is wrong, I can reproduce rendering
http://www.castlesofpoland.com/moz2.jpg easily with a firefox 0.8 release build
(Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206
Firefox/0.8).
If I hit the url in the bug and go directly to the page I see the moz2
rendering. If I hit then back and go back to the bug and then forward to see the
page again I see rendering moz3.jpg. The regression window seems to me wrong.
Summary: page looks unusable in 1.8a1 BuildID 2004060908 and later → links not shown over td background images

Comment 19

15 years ago
(In reply to comment #18)
> I think that comment # 13 is wrong,  The regression window seems to me wrong.

Sorry, the regression window is for the testcases, and the testcases are
concentrating on the error with the background, and I did all test on Windows98 

Probably the testcases belong to Bug 241161 [quirks] empty TABLE should hide
or Bug 246213  	Color missing from stock quote entries 

They regressed on Mozilla BuildID 2004060908 and on Firefox 1.8a2: 2004060908
They are still regressed on Mozilla Build ID 2004061123, 
but they are working on Firefox 1.8a2: 2004061113

Comment 20

15 years ago
Could you attach a expected and wrong rendering of the testcase as it seems to wfm
winxp 2004061008

Comment 21

15 years ago
Created attachment 150697 [details]
screenshot 2004060809 working

Win98SE, 800x600, nVidia nForce integrated grafics

Comment 22

15 years ago
Created attachment 150698 [details]
screenshot 2004060908 regressed

Win98SE, 800x600, nVidia nForce integrated grafics

Comment 23

15 years ago
NOW related to Bug 246213?

Comment 24

15 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a2) Gecko/20040705

feel free to reopen if bug is still seen in a current Mozilla.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 25

15 years ago
it's not fixed in current mozilla. open the link: http://www.biblioteka.elk.pl/
you should see the faulty page. compare with IE.

sometimes I refreshed (F5) and the page looked fine (after refreshing)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040711
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 26

15 years ago
one more thing: small testcase and minimal test case look the same on mozilla
and IE (don't look like "regressed"). I guess those are not correct testcases
for the problem. check the website: http://www.biblioteka.elk.pl/

Comment 27

15 years ago
(In reply to comment #25)
> it's not fixed in current mozilla. open the link: http://www.biblioteka.elk.pl/
> you should see the faulty page. compare with IE.

WFM with Mozilla 2004070807 on WinNT4.

Comment 28

15 years ago
Is also WFM in FF 0.9.2 on Win2k

Comment 29

14 years ago
WFM, Mozilla 2004073115 CVS build on WinME.

Marking WORKSFORME
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 30

14 years ago
(In reply to comment #29)
> WFM, Mozilla 2004073115 CVS build on WinME.
> 
> Marking WORKSFORME

which one of those screenshots it closest to what you see?
http://www.castlesofpoland.com/moz.jpg
http://www.castlesofpoland.com/moz2.jpg
http://www.castlesofpoland.com/moz3.jpg
http://www.castlesofpoland.com/moz4.jpg

Comment 31

14 years ago
(In reply to comment #30)
> which one of those screenshots it closest to what you see?

moz3.jpg is it. Mozilla 2004072808 on WinNT4.
(Reporter)

Comment 32

14 years ago
I downloaded the latest nightly snapshot. I closed and uninstalled mozilla. I 
deleted c:\program files\mozilla.org. I deleted mozilla from my profile - 
Application Data\Mozilla. This is what I get: 
http://www.castlesofpoland.com/moz5.jpg
It's still buggy
(Reporter)

Comment 33

14 years ago
this is w2k. I tested it on three computers. I also deleted the keys in HKLM and
HKCU
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 34

14 years ago
I'm trying this website with new firefox 1.0rc1 and the page still looks
incorrectly: http://www.biblioteka.elk.pl/

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041026
Firefox/1.0RC1

Comment 35

14 years ago
URL and minimal testcase both WFM using Mozilla Nightly 2005022305 on Windows XP.

Comment 36

13 years ago
URL and both testcases WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060527 Minefield/3.0a1 ID:2006052705
Can this be closed?

Updated

10 years ago
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.