Find dialog text field broken

RESOLVED DUPLICATE of bug 252371

Status

()

RESOLVED DUPLICATE of bug 252371
14 years ago
10 years ago

People

(Reporter: cmhofman, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

The text field in the Find dialog for the (Edit -> Find in This Page) can not be
selected, therefore text can not be entered to find in the page. Moreover, after
one has unsuccesfully tried to do this, the navigation in any other text field
is broken: the arrow buttons do not work anymore in a text field. 

Reproducible: Always
Steps to Reproduce:
1. Open a page in Firefox (that may includes a text field)
2. Choose Edit -> Find in This Page
3. Try to select the text field
4. Try to enter text to search
5. Select any other text field in the page
6. Select the text field and enter text
7. Use the left arrow to navigate backwards in the text

Actual Results:  
At 3 the text field in the Find dialog does not get selected. 
At 4 single text does not appear in the text field, and in the main window the a
next match of the last entered single character is highlighted. 
At 7 nothing happens. 

Expected Results:  
At 3 the text field should be selected and focussed.
At 4 the entered text should appear in the text field and matched text for the
full entered text should be highlighted. 
At 7 the cursor in the text field should move backward.

Comment 1

14 years ago
This works for me without any problems with 0.9.3. I don't remember having any
problems with earlier builds either. Christiaan, 0.8.0 is getting on a bit now,
please can you try with a recent build (either 0.9.3 or a recent trunk nightly)
and report back on whether this is still a problem for you.
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> This works for me without any problems with 0.9.3. I don't remember having any
> problems with earlier builds either. Christiaan, 0.8.0 is getting on a bit now,
> please can you try with a recent build (either 0.9.3 or a recent trunk nightly)
> and report back on whether this is still a problem for you.

I am using 0.9.3 now, but I am having the same problem. It might be related to
another bug I reported, Bug 246805 about selection of multiple windows, although
things go a bit different (the find window never works for me, while the window
selection works when I move to another application first). One point in that bug
was that it seems related to the use of CodeTek's virtual desktop, so that might
alos be the case here (I have not tried that out yet). 

Comment 3

14 years ago
Now, there is no Find dialog.
It is replaced with Find Toolbar.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.7.2) Gecko/20040822
Firefox/0.9.1+
known (it is a workaround until 1.0, probably)

*** This bug has been marked as a duplicate of 252371 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.