All users were logged out of Bugzilla on October 13th, 2018

Startup Process Conflict with Thunderbird

RESOLVED INVALID

Status

RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: steve.kunzer, Unassigned)

Tracking

Trunk
Other
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20031111
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20031111

On JDS (Java Desktop System 2003) I was running Thunderbird version 0.6
(20040507) and tried to open a browser window using Mozilla 1.4 for Sun Java
Desktop System <Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20031111>.
I got an Alert with the message "Error launching browser window: TypeError:
Components.classes['@mozilla.org/appshell/component/browser/instance;1'] has no
properties.

I *think* that Mozilla is checking to see whether there's a mozilla process
already running, finding one and telling it to open a browser window. But the
mozilla process that's running is actually Thunderbird which can't open a
browser window! If Thunderbird is not running then Mozilla opens a browser
window as normal. If Firefox is running, (but not Thunderbird) then starting
Mozilla actually opens a Firefox window (which is what leads me to believe it's
just telling whatever mozilla process that's already running what to do). 

An additional piece of information is that if Thunderbird is running (whether it
was started before Firefox or after it), Mozilla produces the same results -
which is odd, since I would have expected it to pick up the 'first' mozilla
process it found (e.g. if Firefox was started first then 'a' mozilla process
would then be running first, before Thunderbird - but I get the same results).

Reproducible: Always
Steps to Reproduce:
1.Run JDS (!!)
2.Start Thunderbird
3.Start Mozilla

Actual Results:  
See Details

Expected Results:  
It should have started a Mozilla browser window.

Severity level is minor for me because I often use Firefox anyway which works
well with Thunderbird (i.e. no conflicts), however if anyone uses Thunderbird
with the Mozilla browser then it'd be a pain because they'd have to close e-mail
in order to browse!
(In reply to comment #0)
> I *think* that Mozilla is checking to see whether there's a mozilla process
> already running, finding one and telling it to open a browser window.

where did you get mozilla from? blame your vendor. mozilla from mozilla.org does
not do that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.