After few window.open, popup blocker block new window.open (even if popup blocker is disabled!!!)

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: coin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040607 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040607 Firefox/0.8.0+

Disable popup blocker. As you can see on
http://tbasic.free.fr/bugzilla/bug_popup.htm, the first time a popup appears.
Close the popup and reload the page, popup blocker now block window.open script!

Reproducible: Always
Steps to Reproduce:
1. Disable popup blocker in the preferences
2. call window.open with the windowName (2nd param) few times (only one window
appears becose of the same name)
3. close the popup
4. reload the main page

Actual Results:  
The popup does not appears anymore.

Expected Results:  
Because popup blocker is disabled, the popup should has opened!

Tested on Windows XP and Mac Os X. This bug appears on nighly builds since few
weeks. It is still present on Mozilla 1.7rc3 and FireFox nighly builds.
(Reporter)

Comment 1

15 years ago
Created attachment 150447 [details]
testcase

Comment 2

15 years ago
The testcase works for me using Firefox 0.8.
(Reporter)

Comment 3

15 years ago
Seems fixed in latest Mozilla nightly builds!

(but still present in FireFox 0.9.1 & FireFox nightly builds)
(Reporter)

Comment 4

15 years ago
Seems to be fixed in latest FireFox nightly too.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040701
Firefox/0.8.0+
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 5

15 years ago
No fix specified.

->WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

15 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.