When visiting sites that have only a horizontal scrollbar at the bottom, the mouse scrollwheel doesn't work

RESOLVED DUPLICATE of bug 121896

Status

()

RESOLVED DUPLICATE of bug 121896
15 years ago
14 years ago

People

(Reporter: randomevent, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

When visiting sites that have only a horizontal scrollbar at the bottom, the
mouse scrollwheel doesn't work.
Oddly enough this works properly in Firefox 0.8 (I am currently using Firefox
0.9 RC), so it was obviously just overlooked.
Also if you open the above site in IE, you will notice that there is a moving
navigation bar built-in to the site that doesn't work in any version of Firefox
(although this technology is rarely used so I understand a fix isn't likely to
make it in anytime soon).

Reproducible: Always
Steps to Reproduce:
1.Open browser
2.Go to www.korg.com (it happens on other sites as well)
3.Try using the mouse or trackball's scrollwheel

Actual Results:  
The scrollwheel didn't work at all for the horizontal scrollbar.

Expected Results:  
The browser should have automatically detected the horizontal scrollbar and
allowed me to use the scrollwheel to navigate.  This works correctly in IE and
Firefox 0.8.
is this still a problem in FF1.0PR or RC1 ?

Comment 2

14 years ago
I don't experience this in 1.0RC1. (Vertical) scrolling wheel and horizontal
tilt work as expected and middle click shows the
horizontal-scroll-on-mouse-move-thingy on given URL and some other test pages.

Sounds like a WORKSFORME.

Comment 3

14 years ago
Dupe of bug 121896?

*** This bug has been marked as a duplicate of 121896 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.