Ensure that MathML compiles successfully in the M15 tarball

VERIFIED FIXED in M15

Status

()

Core
MathML
P3
blocker
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Roland Mainz, Assigned: rbs)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

734 bytes, text/plain
Details
(Reporter)

Description

18 years ago
This is a "tracker" to verify that MathML compiles successfully in the M14
tarballs - the same procedure as described in bug 19238, bug 19398 and bug
22308.
(Reporter)

Comment 1

18 years ago
ToDo list for M14:
- Add a XML demo menu item to Mozilla's demo menu
- Force the Mozilla staff that MathML gets in per default (e.g. without setting
explicitly --enable-mathml)
- What about printing/clipboard support ?

----

Clipboard:
I don't know how Unix clipboard works, but in java theres the ability to get
different representations of the same data ("DataFlavors").
Best would be to deliver the following "flavorws"):
- ASCII-only math
- ASCII-Art embedded in HTML tags (e.g. fixed with)
- text/mathml

Any comments ?
Printing support should be free. (Roger?)
Cliboard as text support would be nice, but... ouch?!
MathML in nightlies is bug 15391.
Target Milestone: M14
(Assignee)

Comment 3

18 years ago
Printing requires filling some stubs (in GFX). Not really a big deal. And... it
is hoped that the quality is going to be really high than on the screen!
Clipboard as (disorganised) text is going to be ok too :-)
But ascii art is where the trouble is. Probably should be postponed
as a later enhancement.
(Assignee)

Comment 4

18 years ago
Useful link which provides fonts that could be used for *ascii* output/art.
http://www.cl.cam.ac.uk/~mgk25/ucs-fonts.html

See in particular the screenshot (and the comments therein):
http://www.cl.cam.ac.uk/~mgk25/ucs/yudit-6x13.gif
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 5

18 years ago
I can't compile M14 tarball with --enable-mathml:
-- snip --
cd base; make libs
make[3]: Entering directory
`/home/gisburn/package-builds/mozilla5/mozilla/objdir_gcc/layout/mathml/base'
cd src; make libs
make[4]: Entering directory
`/home/gisburn/package-builds/mozilla5/mozilla/objdir_gcc/layout/mathml/base/src'
c++ -o nsMathMLChar.o -c -fno-rtti -fno-exceptions -pedantic -Wno-long-long -O
-g -DMOZILLA_CLIENT -include ../../../../config-defs.h
-Wp,-MD,.deps/nsMathMLChar.pp -DOSTYPE=\"SunOS5\" -DOJI 
-I../../../../../layout/mathml/base/src/../../../base/src
-I../../../../../layout/mathml/base/src/../../../base/public
-I../../../../../layout/mathml/base/src/../../../html/style/src
-I../../../../../layout/mathml/base/src/../../../html/base/src
-I../../../../../layout/mathml/base/src/../../../html/content/src
-I../../../../../layout/mathml/base/src/../../../html/table/src
-I../../../../../layout/mathml/base/src/../../content/src 
-I../../../../dist/include -I../../../../../include  -I../../../../dist/include
-I../../../../dist/include -I../../../../dist/include -I/usr/dt/include   -fPIC
../../../../../layout/mathml/base/src/nsMathMLChar.cpp
c++ -o nsMathMLContainerFrame.o -c -fno-rtti -fno-exceptions -pedantic
-Wno-long-long -O -g -DMOZILLA_CLIENT -include ../../../../config-defs.h
-Wp,-MD,.deps/nsMathMLContainerFrame.pp -DOSTYPE=\"SunOS5\" -DOJI 
-I../../../../../layout/mathml/base/src/../../../base/src
-I../../../../../layout/mathml/base/src/../../../base/public
-I../../../../../layout/mathml/base/src/../../../html/style/src
-I../../../../../layout/mathml/base/src/../../../html/base/src
-I../../../../../layout/mathml/base/src/../../../html/content/src
-I../../../../../layout/mathml/base/src/../../../html/table/src
-I../../../../../layout/mathml/base/src/../../content/src 
-I../../../../dist/include -I../../../../../include  -I../../../../dist/include
-I../../../../dist/include -I../../../../dist/include -I/usr/dt/include   -fPIC
../../../../../layout/mathml/base/src/nsMathMLContainerFrame.cpp
../../../../../layout/mathml/base/src/nsMathMLContainerFrame.cpp: In method
`nsresult nsMathMLContainerFrame::InsertScriptLevelStyleContext(nsIPresContext
*)':
../../../../../layout/mathml/base/src/nsMathMLContainerFrame.cpp:833: no
matching function for call to `nsStyleUtil::FindNextSmallerFontSize (PRInt32 &,
PRInt32 &, float &)'
../../../../dist/include/nsStyleUtil.h:48: candidates are: static PRInt32
nsStyleUtil::FindNextSmallerFontSize(int, int, float, nsIPresContext *)
../../../../../layout/mathml/base/src/nsMathMLContainerFrame.cpp:834: no
matching function for call to `nsStyleUtil::CalcFontPointSize (PRInt32 &,
PRInt32 &, float &)'
../../../../dist/include/nsStyleUtil.h:46: candidates are: static nscoord
nsStyleUtil::CalcFontPointSize(int, int, float, nsIPresContext *, nsFontSizeType
= eFontSize_HTML)
make[4]: *** [nsMathMLContainerFrame.o] Error 1
make[4]: Leaving directory
`/home/gisburn/package-builds/mozilla5/mozilla/objdir_gcc/layout/mathml/base/src'
make[3]: *** [libs] Error 2
make[3]: Leaving directory
`/home/gisburn/package-builds/mozilla5/mozilla/objdir_gcc/layout/mathml/base'
make[2]: *** [libs] Error 2
make[2]: Leaving directory
`/home/gisburn/package-builds/mozilla5/mozilla/objdir_gcc/layout/mathml'
make[1]: *** [libs] Error 2
make[1]: Leaving directory
`/home/gisburn/package-builds/mozilla5/mozilla/objdir_gcc/layout'
make: *** [libs] Error 2
-- snip --

Any comments ?
(Assignee)

Comment 6

18 years ago
The call to nsStyleUtil::FindNextSmallerFontSize() in nsMathMLContainerFrame
is wrong due to changes in the Style System API.
The problem is that the call is
  nsStyleUtil::FindNextSmallerFontSize(PRInt32 &, PRInt32 &, float &)
instead of:
  nsStyleUtil::FindNextSmallerFontSize(int, int, float, nsIPresContext *)

i.e., you should add 'aPresentationContext' as last argument in the call.

cls fixed the problem on the tip (but not on the M14 branch/tarball).

Comment 7

18 years ago
actually, this is m15, but i'll add it here anyway so the rest of you see it.
I noticed that mathml was broken when i compiled after troy's carpool last
night.

nsMathMLmactionFrame.cpp
c++ -o nsMathMLmactionFrame.o -c -fno-rtti -fno-exceptions -Wall -Wconversion
-Wpointer-arith -Wbad-function-cast -Wcast-align -Woverloaded-virtual -Wsynth
-Wshadow -pedantic -Wno-long-long -pthread -g -DMOZILLA_CLIENT -include
../../../../config-defs.h -Wp,-MD,.deps/nsMathMLmactionFrame.pp
-DOSTYPE=\"Linux2.2\" -DOJI 
-I/home/endico/mozilla/mozilla/layout/mathml/base/src/../../../base/src
-I/home/endico/mozilla/mozilla/layout/mathml/base/src/../../../base/public
-I/home/endico/mozilla/mozilla/layout/mathml/base/src/../../../html/style/src
-I/home/endico/mozilla/mozilla/layout/mathml/base/src/../../../html/base/src
-I/home/endico/mozilla/mozilla/layout/mathml/base/src/../../../html/content/src
-I/home/endico/mozilla/mozilla/layout/mathml/base/src/../../../html/table/src
-I/home/endico/mozilla/mozilla/layout/mathml/base/src/../../content/src 
-I../../../../dist/include -I/home/endico/mozilla/mozilla/include    
-I/usr/X11R6/include   -fPIC nsMathMLmactionFrame.cpp
In file included from nsMathMLmactionFrame.cpp:44:
../../../../dist/include/nsIWebBrowserChrome.h:71: warning: decimal integer
constant is so large that it is unsigned
/home/endico/mozilla/mozilla/layout/mathml/base/src/../../../html/base/src/nsFrame.h:197:
warning: `nsFrame::HandleEvent(nsIPresContext *, nsGUIEvent *, nsEventStatus *)'
was hidden
In file included from nsMathMLmactionFrame.cpp:50:
nsMathMLmactionFrame.h:92: warning:   by
`nsMathMLmactionFrame::HandleEvent(nsIDOMEvent *)'
nsMathMLmactionFrame.cpp: In method `nsresult nsMathMLmactionFrame::Init(class
nsIPresContext *, class nsIContent *, class nsIFrame *, class nsIStyleContext *,
class nsIFrame *)':
nsMathMLmactionFrame.cpp:112: warning: unused variable `nsresult rv'
nsMathMLmactionFrame.cpp: In function `static nsresult
nsMathMLmactionFrame::ShowStatus(class nsIPresContext *, class nsString &)':
nsMathMLmactionFrame.cpp:397: warning: implicit declaration of function `int
do_GetInterface(...)'
nsMathMLmactionFrame.cpp:397: warning: cannot pass objects of type
`nsCOMPtr<nsIDocShellTreeOwner>' through `...'
nsMathMLmactionFrame.cpp:397: no matching function for call to
`nsCOMPtr<nsIWebBrowserChrome>::nsCOMPtr (int)'
../../../../dist/include/nsCOMPtr.h:461: candidates are:
nsCOMPtr<nsIWebBrowserChrome>::nsCOMPtr<nsIWebBrowserChrome>()
../../../../dist/include/nsCOMPtr.h:468:                
nsCOMPtr<nsIWebBrowserChrome>::nsCOMPtr<nsIWebBrowserChrome>(const
nsCOMPtr<nsIWebBrowserChrome> &)
../../../../dist/include/nsCOMPtr.h:476:                
nsCOMPtr<nsIWebBrowserChrome>::nsCOMPtr<nsIWebBrowserChrome>(nsIWebBrowserChrome
*)
../../../../dist/include/nsCOMPtr.h:486:                
nsCOMPtr<nsIWebBrowserChrome>::nsCOMPtr<nsIWebBrowserChrome>(const
nsDontAddRef<nsIWebBrowserChrome>
&)../../../../dist/include/nsCOMPtr.h:493:                
nsCOMPtr<nsIWebBrowserChrome>::nsCOMPtr<nsIWebBrowserChrome>(const
nsCOMPtr_helper &)
../../../../dist/include/nsCOMPtr.h:505:                
nsCOMPtr<nsIWebBrowserChrome>::nsCOMPtr<nsIWebBrowserChrome>(const
nsQueryInterface &)
gmake[5]: *** [nsMathMLmactionFrame.o] Error 1
gmake[5]: Leaving directory
`/home/endico/mozilla/mozilla/layout/mathml/base/src'
gmake[4]: *** [install] Error 2
gmake[4]: Leaving directory `/home/endico/mozilla/mozilla/layout/mathml/base'
gmake[3]: *** [install] Error 2
gmake[3]: Leaving directory `/home/endico/mozilla/mozilla/layout/mathml'
gmake[2]: *** [install] Error 2
gmake[2]: Leaving directory `/home/endico/mozilla/mozilla/layout'
gmake[1]: *** [install] Error 2
gmake[1]: Leaving directory `/home/endico/mozilla/mozilla'
gmake: *** [build] Error 2


(Assignee)

Comment 8

18 years ago
Changing title and milestone target. The "bug" wasn't fixed :-)

Dawn, it should be okay now. It was bug 31512 - Latest webshell changes
break mathML build.
Summary: Ensure that MathML compiles successfully in the M14 tarball → Ensure that MathML compiles successfully in the M15 tarball
Target Milestone: M14 → M15

Comment 9

18 years ago
cc ing

Comment 10

18 years ago
it took me a few days to get to this but yes, mathml builds for me on 
linux now. thanks!

Comment 11

18 years ago
There was a slight glitch yesterday. But (just to confirm that Roger's linux

patch works) -it is fine today Thursday 00:45 GMT.

(Assignee)

Comment 12

18 years ago
Release people asked what is going on regarding this bug. As there is no
reported compilation problems, I am taking this bug off the radar of M15.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

18 years ago
Created attachment 8551 [details]
foo bar
(Reporter)

Comment 14

18 years ago
Ahhgrrlll, sorry. 
Ignore the attachment (is there a way to delete it ??)

(I was using a modified version of the createattachment form to create output
for a bug-report to someone else and used the wrong window...).

SORRY !!!!

Rubberstamping verified; "the proof is in the pudding" and all that.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.