Cursor invisible in input field, when parrent div is defined over another div with overflow set to auto

RESOLVED DUPLICATE of bug 223239

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 223239
14 years ago
14 years ago

People

(Reporter: Rastislav Graus, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608

When in an floating div element an input field defined ist and this div is
positioned over another div element with overflow set to auto, only that part of
cursor ist visible, which is not over the scrollable div.

Sorce for error reproduction is:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<HTML>
	<HEAD>
		<META http-equiv="content-type" content="text/html;charset=windows1250">
		<TITLE>Test</TITLE>
		<STYLE type="text/css">
			DIV.first {
				background-color: red;
				position: absolute;
				overflow: auto;
				top: 50px;
				left: 50px;
				width: 400px;
				height: 200px;
				padding: 5px;
			}
			DIV.second {
				background-color: yellow;
				position: absolute;
				width: 200px;
				height: 100px;
				padding: 5px;
			}
		</STYLE>
	</HEAD>
	<BODY>
		<DIV class="first" style="overflow: hidden; top: 50px; left: 50px;">
			DIV with owerflow: hidden;
		</DIV>
		<DIV class="second" style="top: 100px; left: 100px;">
			Field1: <INPUT type="text" size="10" value=""/>
		</DIV>

		<DIV class="first" style="overflow: auto; top: 350px; left: 50px;">
			DIV with owerflow: auto;
		</DIV>
		<DIV class="second" style="top: 400px; left: 100px;">
			Field2: <INPUT type="text" size="10" value=""/>
		</DIV>

		<DIV class="first" style="overflow: auto; top: 350px; left: 550px;">
			DIV with owerflow: auto;
		</DIV>
		<DIV class="second" style="top: 335px; left: 730px;">
			Field3: <INPUT type="text" size="10" value=""/>
		</DIV>
	</BODY>
</HTML>


Reproducible: Always
Steps to Reproduce:
1. Store the source written in detailed description of this bug into the
test.html file
2. Open the Mozilla Browser and open the file test.html in broser.
3. Click with mouse successively each input field

Actual Results:  
Field 1: cursor is visible - correct (because underlying red div has overflow
set to hidden)

Field 2: cursor is not visible - error

Field 3: cursor is partialy visible - error

Expected Results:  
In all cases (all three fields) have cursor to be visible
(Reporter)

Comment 1

14 years ago
Created attachment 150521 [details]
The test.html file described in the bug report
(Reporter)

Updated

14 years ago
Attachment #150521 - Attachment description: The test.html file described ind bug report → The test.html file described in the bug report

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 223239 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.