Forwarding posts from newsgroups to email recipient

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Padraig Finnerty, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8


There are 2 problems here. 

One is if you forward a newsgroup post to an email recipient,
the message doesn't appear in your 'sent' folder. This makes it
confusing, as you're wondering if it's actually been sent or not.

The second problem is that it sets the 'from' address to the
one specified in the newsgroup account. I've got a fake address
in my newsgroup account to stop me getting spam (as most people
have), but if I'm forwarding a post to a friend, I don't want to 
send them the fake 'from' address. I think if you're forwarding 
to an email address it should use your main email 'from' address 
(like Outlook Express does).

Thanks.
Padraig Finnerty



Reproducible: Always
Steps to Reproduce:
1. Just forward a newsgroup post to an email address.
2.
3.

Comment 1

14 years ago
> One is if you forward a newsgroup post to an email recipient,
> the message doesn't appear in your 'sent' folder.

Which sent folder? Did you look into Local Folders/Sent?

> The second problem is that it sets the 'from' address to the
> one specified in the newsgroup account.

Of course. You're free to change the From: via the drop-down.
Mozilla could preselect the address of the default account although that would
be wrong for may people too. It would also be wrong for all people with a normal
mail address in the news accounts identity. And what if you forward to a mail
address and a newsgroup?
Preselecting the From: of the selected account is just consistent and causes the
least trouble I think.
Component: General → Message Compose Window
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Comment 2

14 years ago
>> One is if you forward a newsgroup post to an email recipient,
>> the message doesn't appear in your 'sent' folder.
>
> Which sent folder? Did you look into Local Folders/Sent?

Ok yeah, it is in 'Local Folders/Sent' (still a bit unintuitive
that it would go to a different folder than your normal 
mails).


>> The second problem is that it sets the 'from' address to the
>> one specified in the newsgroup account.
>
> Of course. You're free to change the From: via the drop-down.
> Mozilla could preselect the address of the default account although that would
> be wrong for may people too. It would also be wrong for all people with a normal
> mail address in the news accounts identity. And what if you forward to a mail
address and a newsgroup?
> Preselecting the From: of the selected account is just consistent and causes the
> least trouble I think.

Ok fair point. I didn't realise you could change the from
address so easily.


Comment 3

14 years ago
> (still a bit unintuitive that it would go to a different folder
> than your normal mails)

If it's sent composed with a news identity, it goes in the folder for this
identity. Since newsservers itself don't have a own Drafts/Sent/Trash folder.
If you change the From: to one of your normal mail identities, the sent copy
will go (or should at least) in the appropriate Sent folder.

Comment 4

14 years ago
=>WFM per reporter's comment 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.