Firefox repeatedly tries and fails to start, and can only be stopped through terminal

VERIFIED DUPLICATE of bug 246789

Status

()

--
critical
VERIFIED DUPLICATE of bug 246789
15 years ago
10 years ago

People

(Reporter: kelson, Assigned: benjamin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

When trying to run the RC of FireFox 0.9, it got through the settings migration,
then the icon started appearing and disappearing on the dock (without actually
loading a menu or window).  Force quit couldn't stop it - it kept appearing and
disappearing from that list, and quitting it accomplished nothing.  I tried to
reboot, but it canceled my shutdown.  (Really: a message box came up and said
"Firefox cancelled shutdown."  I finally opened up Terminal, and ps revealed
that it was starting a new process (with a new PID) every time, which is why
force quit failed and why I couldn't kill it by PID.  Finally I just ran
"killall firefox-bin", which took cqare of it.

I initially ran it directly from the disk image (since I didn't want to
overwrite my copy of FF 0.8).  Later, after getting it to close, I copied it to
my desktop and ran it from there, at which point it loaded fine (I'm using that
session to submit this bug).

Reproducible: Couldn't Reproduce
Steps to Reproduce:
1. Downloaded Firefox 0.9rc
2. Double-clicked on Firefox icon in disk image (this may have been the problem)
3. After the notice about successful migration, clicked on OK/quit/whatever the
one and only button was labeled.

Actual Results:  
Firefox kept appearing on the Dock, then disappearing, then appearing again. 
Force quit couldn't, and shutdown got canceled, and finally I was able to stop
it with terminal and killall.

Expected Results:  
Firefox should have started up completely or failed - once - with an error.

Firefox 0.8 is also installed on this system, but was not running. Classic
environment was running, but no classic-mode apps were open.  This is a
fully-updated Panther on a PowerBook.  The only other programs running were
Finder, Safari, and possibly IE and/or Camino (I'd been doing some web design
testing earlier).

At this point, I'm not sure if the problem was caused by it being the first run,
or if it was caused by running it from the dmg instead of copying it to the disk
first.  (I'm fairly new to Mac OS, so I don't know if running it from the dmg
was a bonehead move on my part. Even so, I can see a total newbie doing this,
and not having the CLI and unix knowledge that saved me.)

Comment 1

15 years ago
*** Bug 246495 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
Can someone upgrade my status to canconfirm? or confirm in this instance? thanks!

bug 246495 is a dupe of this bug, I haven't stopped application with terminal,
but assume this would work.

This bug remains critical, as in my experience applications are expected to work
'directly from the disk image' and I didn't even consider that dragging to the
desktop might be a solution.

I also 'normally' check the application from the disk image before choosing
where to file the application, ie in this case in the bin.

Comment 3

15 years ago
oops:

It is definitely nothing to do with 'first run' and exclusively to do with not
copying to another location, before opening.

Comment 4

15 years ago
It being my third day of using OSX, I thought I was doing something wrong. 
Apparently not!  Just wanted to add that I'm seeing the exact same problem in
the exact same circumstances.

One extra thing.. is the fact that Firefox is listed in Applications in all
lower-case an aesthetic bug?  I was fairly certain 0.8 had it properly capitalized.

Comment 5

15 years ago
I hate duping older bugs to new bugs... but since bug 246789 was marked new by
the assignee (who also owns this bug)... I feel as if its the best solution.
Depends on: 246789
(Assignee)

Comment 6

15 years ago
Pretty much the same bug as 245441, which I thought we fixed before 0.9. 
Investigating.

Comment 7

14 years ago
I have to agree with Riscky it's 99% a dupe of bug 246789.  Reporter, if you
think this is incorrect please reopen.

Thanks

*** This bug has been marked as a duplicate of 246789 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.