If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Manual theme/extension installation

RESOLVED FIXED in mozilla1.8.1alpha2

Status

()

Toolkit
Add-ons Manager
--
enhancement
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Alex Eng, Assigned: rstrong)

Tracking

({fixed1.8.1})

unspecified
mozilla1.8.1alpha2
fixed1.8.1
Points:
---
Bug Flags:
blocking-aviary1.5 -
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
The Extension Manager and Theme Manager windows should have a button or
hyperlink, perhaps with the caption "Install from File...", so that users can
install an extension or theme from a downloaded XPI or JAR file.  Dragging and
dropping an XPI or JAR file into the Extension Manager or Theme Manager window
may not be obvious to some users.

Comment 1

14 years ago
I agree, this would be a minor polish. 
Some people maybe don't know, that you can easy drag & drop themes to the theme
manager. An install button would be very helpful. I tested one of the latest
Thunderbird builds, now, there is the same Theme/Extension manager like in
Firefox, but with an install button. The theme manager in TB also supports drag
& drop, so the install button is no more needed like before. But, why not just
include this button in Firefox, too?

Maybe after 1.0? 

Comment 2

13 years ago
*** Bug 247091 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
This is not just a "minor polish." Just how would you know that you should drag
an extension into an open browser window? Or--yet more obscure--into an open
Theme Manager dialog window? Note that the latter is not the same as the former.

At the very least, the Extension Manager and theme Manager dialog windows should
include instructions on how to install an extension or a theme.

When we get to 1.0, do you really want newbies flooding the Mozillazine forums
asking how to do this? Or worse, giving up in disgust and going away?

Comment 4

13 years ago
i agree with comment 3, it is a minor polish thing but i think it needs to be 
done. Before 1.0
Should we mark this blocking 1.0 ?

Comment 5

13 years ago
Please, see also my comments under bug 247091

Comment 6

13 years ago
Currently Thunderbird has an install button for Themes and Extensions.  For the
sake of uniformity and use this somewhat simple polish should be added to
Firefox for the 1.0 release.

What's nice is that Themes button defaults to *.jar file extension and the
Extension to *.xpi file extension, would love to see this for FF, thanks.

Comment 7

13 years ago
Voted.  Agreed, buttons are needed so new users have something logical to go on
(i.e., clicking a button) instead of the not-so-obvious drag 'n' drop we
"vetrans" have become used to.

Comment 8

13 years ago
Can this PLEASE be nominated for 1.1?  If Thunderbird 1.0.2 has this, then 1.1
should have it.  This seems very trivial, and should take only a few moments to
add a button to the UI.

Comment 9

13 years ago
Yeah I couldn't wait so I created MR Tech's Local Install:
http://www.mrtech.com/extensions/

I allows multiple installs for extensions and filters for *.xpi or *.jar and a
bunch of other goodies coming with the next release.

More info here: http://forums.mozillazine.org/viewtopic.php?t=183967

Comment 10

13 years ago
Yeah, I know about your extension and use it myself, but it should be something
that should have been fixed by 1.0.
I ported this button from Thunderbird to Deer Park Alpha 1 today. I wanted to
test how it's difficult. I think that's easy but i have two questions:

1) In file extensions.js i found something like this:

//////////////////////////////////////////////////////////////////////////
// functions to support installing of themes in apps other than firefox //
//////////////////////////////////////////////////////////////////////////

Is there any problem with this code in Firefox? I didn't found anything.

2) I didn't found usefull icon in actual theme for this button.

I don't have time to create a patch at this moment - maybe later. 
Created attachment 186701 [details]
Preview of my "port"

Comment 13

12 years ago
It's crazy that this isn't include at the VERY least in Linux builds.  So many
systems do NOT include gui filemanagers, and even in the mix of those that do
MANY do not support drag and drop features.. and then FURTHER using those that
do support and dragging and dropping jar files tosses up a ton of gtk errors,
sometimes crashes the browser, and is generaly buggy.

And, let us not forget the OSX builds where dragging and dropping work not even
a little.

I know that my use of the theme manager is probably a little bit more intense
than most peoples (and I'm sure that mr. Hume will agree with me on this) but as
a theme developer this system is just ludicrous.

MrTechs Local Install Extension
https://addons.mozilla.org/extensions/moreinfo.php?id=421

is currently the only REAL solution I've found for this, and it's helped my
trouble shoot several linux users troubles installing themes/extensions from a
local file.  Something similar to it's feature set would be just fine.

Please... for the sake of meshing with the other operating systems.  Many of
them don't work with drag and drop, they don't have that as a focus, and it
doesn't make sense in the realm of using them to consider installing in this
fashion.

Give us a command line method, give us a button like the local install
extension, give us something! But relegating all Linux users to a world of gui
filemanagers is simply rediculous (we don't all use gnome, or kde).

Thanks,
Anders

Comment 14

12 years ago
There is another extension that add an install button to the theme manager (not
the extension manager):
https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&id=496

I personally like the yellow button that comes with "MrTechs Local Install
Extension", rest of the stuff from that extension can probably be dropped (aka
the shortcuts stuff).


Would be a great feature to be included in firefox, I personally don't have a
file manager to drag'n drop from.

Updated

12 years ago
Flags: blocking-aviary1.1?
File->Open works just fine instead of drag'n'drop.  Not going to block 1.1 on
this, we're going to revisit the extension manager UI for the next release.
Flags: blocking-aviary1.1? → blocking-aviary1.1-
(In reply to comment #15)
> File->Open works just fine instead of drag'n'drop.  Not going to block 1.1 on
> this, we're going to revisit the extension manager UI for the next release.

... but only for extensions, not themes!

Updated

12 years ago
Flags: blocking-aviary2.0?
This feature already exists for Thunderbird's EM and TM, as Thunderbird does not have the proper infrastructure hooked up to its filepickers.

Exposing this feature for Firefox would be simple. But is it really necessary?
not a blocker, but a nice to have.
Assignee: bugs → nobody
Flags: blocking-aviary2? → blocking-aviary2-
QA Contact: bugs → extension.manager
*** Bug 323325 has been marked as a duplicate of this bug. ***

Comment 20

12 years ago
You are crazy if you don't understand this simply thing. Install button strongly needed for extension manager. Ask any national support team about this, to you will answer, what thousand people ask "How I can install extension? I can't find button...". Please, keep our time and our reason. Think about people.  Make this button in Firefox 2.0
Why are so many people downloading extensions to install locally?  I don't see a case where local install is really necessary in a web browser...

Comment 22

12 years ago
(In reply to comment #21)
> Why are so many people downloading extensions to install locally?  I don't see
> a case where local install is really necessary in a web browser...
Because traffic is money in many countries (Russia for example). Because good idea save all installed extensions if you need reinstall Fx (yes, I know, profile don't remove with deinstall Fx, but you can have many situation when you need complete deinstall). Because you can install Fx to the friends and well have all extensions locally. Because you can forget where you have taken extansion. And many other reasons...
(In reply to comment #21)
> Why are so many people downloading extensions to install locally?  I don't see
> a case where local install is really necessary in a web browser...
> 
I do it myself on occasion. Even if it isn't necessary, the fact remains that a lot of people do it and there should be an easy way for the user to install themes and extensions. I think eventually people are going to want to backup their themes/extensions so that they can easily reinstall them after a full system reinstall. That's another bug that's floating around somewhere. Anyway, that would mean a local install is not so far fetched.

Comment 24

12 years ago
Another reason someone might have a local version to install is because they run a program or script (like Automatix: http://www.ubuntuforums.org/showthread.php?t=80295) that upgrades Firefox but does not install themes and extensions while retaining the old ones in a backup directory.  It's left as an exercise to the user to move their themes and extensions (or download them over again).

Ideally, everyone always installs these things from the web, but the world is not ideal and a mature program has the ability to intuitively install from a local file - not just the web.
Depends on: 329045
Fixed on trunk by the checkin for bug 329045
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: nobody → robert.bugzilla
Status: REOPENED → NEW
Status: NEW → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 2 alpha2
Keywords: fixed1.8.1
btw: bug 342656 made the button hidden for Firefox via the pref "extensions.hideInstallButton". The capability is there in Firefox and the Firefox dev team decided it should not be displayed by default.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.