imap i18n internationalisation: folder with accents in their name are not opened

RESOLVED WORKSFORME

Status

Thunderbird
Build Config
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Gummi, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.6) Gecko/20040207 Firefox/0.8

I have folders with names such as Lycée in my imap box, when I open them
thunderbird stays saying "opening folders..." in the status bar, apparently not
getting any answer. But it does list folders correctly (eg when asking to
subscribe to folders). I do not know what encoding is used by the server. This
could affect mozilla mail, I don't know.

Reproducible: Always
Steps to Reproduce:
1.Create a mailbox named Lycée
2.Move some mail here
3.Try to open Lycée

Actual Results:  
Lycée isn't opened

Expected Results:  
Opened it

Comment 1

14 years ago
Gabriel de Perthuis: see bug 255541; does the 'solution' seen there apply to 
your situation?
(Reporter)

Comment 2

14 years ago
I didn't have the courage to try to set hidden preferences, but I suppose this
solution would work.
I've made some quick&dirty dumps, however, and I see that evolution (which
doesn't have the bug) uses this command:
T 192.168.0.1:39510 -> 81.255.54.7:143 [AP]
  A00084 SELECT Accentu&AOk-..

The problem is, I've also seen thunderbird 0.9 use this same name in some quota
commands. I'll try to get better dumps later.
(Reporter)

Comment 3

13 years ago
I'm not using thunderbird currently, so I can't (re-)confirm. Feel free to close.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Component: General → Build Config
Resolution: --- → FIXED
Version: unspecified → 0.9

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 4

13 years ago
Reopened to fix resolution.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.