Bookmark menu is scrolling itself Up with no user intervention.

RESOLVED DUPLICATE of bug 129480

Status

SeaMonkey
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 129480
14 years ago
13 years ago

People

(Reporter: Nikola Milosavljevic, Assigned: Pierre Chanial)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040608
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040608

Error occurs when the previous viewing of the Bookmark list
were stopped at the one of the bookmarks lower than it can fit on the screen.
The Bookmark list scrolls up itself at the moment the Bookmark menu is opened.
It cannot be stopped with mouse scroll, and keyboard arows, only with
scrolling-down arrow arrow.
This is _Urgent_ for final 1.7 beacouse this is RC3!

* CONFIGURATION TESTED
Using Mozilla 1.7RC3 on a Win 2000AS 
(Service Pack 4, IE 6.1,) system, 1280x1024
The Build ID is 20040608

Reproducible: Always
Steps to Reproduce:
1.Open Bookmark meny with many items in root,
  scroll down the bookmarks. Exit Bookmark menu.
2.Click at the Bookmarks menu.
  If the scrolling does not occur, then exit from menu,
  then enter to Bookmarks menu again.
3.The Bookmark list scrolls up itself at the moment the Bookmark menu is opened.
  Positioning pointer on the scrolling-down arrow stops the scrolling. 
  It stops scrolling when it comes to the top.
4.If "End" button is pushed,
  it begins to scroll itself Back to top again and again.
  It cannot be stopped with mouse scroll, and keyboard arows, 
  only with scrolling-down arrow arrow.

Actual Results:  
Bookmarks meny is scrolling itself Back to top again and again.

Expected Results:  
Bookmarks position should Stay at the position where the user left them.
And not scrolling itself without control.

It should be added _PgUP_ and _PgDown Keystrokes_ to scroll Bookmarks 
one "page" at the time (Like _Home_ and _End_ do the positioning now) 


I also have an idea to implement
_PageUp_ and _PageDown_ keystokes to act like showing next screen of bookmarks
(Like Home and End now)

But the previous one is _Urgent_ for the final 1.7 release.
(Reporter)

Comment 1

14 years ago
It looks like bug 244974 and bug 247130 ,
And is maybe related to bug 218106 ,bug 245403, etc.

It certanly needa fix before the final 1.7 release.
Product: Browser → Seamonkey

Comment 2

13 years ago
*** Bug 285865 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
bug 156942 bug 129480

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 129480 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.