Closed Bug 246556 Opened 18 years ago Closed 18 years ago

M17rc3 crashes [@ nsGenericHTMLElement::RecreateFrames] [@ f2416033]

Categories

(Core :: Layout, defect)

x86
Windows 2000
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: syskin2, Assigned: bugzilla-mozilla-20000923)

References

Details

(4 keywords, Whiteboard: fixed-aviary1.0)

Crash Data

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040611 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040611 Firefox/0.8.0+

I've been experiencing many crashes with this nightly. Non-clean profile, but
Silver made me fill a big so he can fix it. Here you go.

Talkback # TB89954H, TB89659X, TB89439M, TB89437Y

Reproducible: Sometimes
Steps to Reproduce:
1. Be unlucky with 1 day old profile
Assignee: nobody → silver
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is an inspection patch, based on the crash location in the talkback
reports and the fact most other uses of mDocument include null-checks.
Comment on attachment 150653 [details] [diff] [review]
Null-check mDocument

This patch is against TRUNK, but it'll need applying to the Aviary branch too.
Keywords: crash, regression
Summary: crashes at nsGenericHTMLElement::RecreateFrames : reading from null → crashes [@ nsGenericHTMLElement::RecreateFrames] [@ f2416033]
Attachment #150653 - Flags: superreview?(jst)
requesting blocking1.7 because it's currently topcrash #4 and there's a patch to
review
Flags: blocking1.7?
Adding M17rc3 to summary and topcrash keyword for tracking...this is a topcrash
for Mozilla 1.7 rc3.
Keywords: topcrash
Summary: crashes [@ nsGenericHTMLElement::RecreateFrames] [@ f2416033] → M17rc3 crashes [@ nsGenericHTMLElement::RecreateFrames] [@ f2416033]
*** Bug 246698 has been marked as a duplicate of this bug. ***
Any chances of having it fixed before Firefox 0.9? Please pretty please, it's
just a null check, it can be reviewed in 30 seconds and even if it's wrong (not
that it is) it will not cause any problems.
Severity: normal → critical
Comment on attachment 150653 [details] [diff] [review]
Null-check mDocument

r+sr=jst
Attachment #150653 - Flags: superreview?(jst)
Attachment #150653 - Flags: superreview+
Attachment #150653 - Flags: review+
Comment on attachment 150653 [details] [diff] [review]
Null-check mDocument

Trivial null check, if we're still taking changes for 1.7, this is a no-risk
crash fix. No idea how frequent of a crash tho...
Attachment #150653 - Flags: approval1.7?
Comment on attachment 150653 [details] [diff] [review]
Null-check mDocument

Leaf says a=leaf
Attachment #150653 - Flags: approval1.7? → approval1.7+
Fix checked in on the 1.7 branch.
Keywords: fixed1.7
Fixed on the trunk too. Thanks for the fix!
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Flags: blocking1.7?
Whiteboard: needed-aviary1.0
Verified on Mozilla 1.7 branch. Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.7) Gecko/20040617. I haven't experienced any crashes with older profiles.
Verified code checkin for this build in nsGenericHTMLElement::RecreateFrames()
in nsGenericHTMLElement.cpp .
http://lxr.mozilla.org/seamonkey/source/content/html/content/src/nsGenericHTMLElement.cpp#539
Keywords: fixed1.7verified1.7
Whiteboard: needed-aviary1.0 → fixed-aviary1.0
*** Bug 248975 has been marked as a duplicate of this bug. ***
Crash Signature: [@ nsGenericHTMLElement::RecreateFrames] [@ f2416033]
You need to log in before you can comment on or make changes to this bug.