message should remain selected when another message marked junk is moved

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED WORKSFORME
14 years ago
6 years ago

People

(Reporter: Eyal Rozenberg, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040602
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040602

My prefs are set to move messages marked as junk to the junk folder.

Now, If I have message selected - say, the third message in some folder, and I
mark, say, the second message as junk (without altering the selection, mind
you), the message marked as junk is moved to the junk folder, and the selection
in my current folder changes: it moves 1 message downwards, i.e. instead of the
selection remaining the same, what remains fixed is the index of the selected
item within the folder. I find this behavior quite annoying and counter-intuitive.

Somewhat related re-selection logic bugs are: bug 65823, bug 241233 (both of
these are IMAP-specific issues, but such that have to do with what happens to a
selection when a message disappears from the current folder).

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
Related to bug 200138 and bug 209748.
(Reporter)

Comment 2

14 years ago
Bug 209748 only claims that the selection should not change when the next
message is junk. I claim the selection should never change if the current
selection remains valid.

Comment 3

14 years ago
Well... the reason *that* bug mentions that 'the message following the selection 
is junk' is because the reporter of that bug is crazy bugeyed paranoid about 
ever having junk mail appear in his preview pane, and therefore thinks the bug 
allows the FBI to gain access to his deepest thoughts, or something like that.

In my eyes, this is clearly a dupe of bug 209748.  The summary of that bug 
states the problem described in this one.
(Reporter)

Comment 4

14 years ago
I would say 209748 depends-on this bug. You can, of course, mark this as a dupe,
but then what's probably going to happen is that someone will write a patch will
causes the selection not change only when the next message is junk, or
something, and then we'll have to re-open this one.

Comment 5

14 years ago
This bug is particularly annoying due to its effect on the read/unread flag.
Here's what happens to me all the time: while having the focus on (say) the 30th
message in the folder, I mark some messages as spam near the top of the folder.
Every such marking moves the marked message to the junk folder, and thus (due to
this bug) moves the focus one message down -- the focus index is preserved while
the content moves. Hence, some arbitrary message gets the focus *and is marked
as read*. I then have to manually restore the unread status of all these
messages status. Highly annoying.
Tested on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a3) Gecko/20040817, and
also on 1.7.2.

Updated

14 years ago
Assignee: sspitzer → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: Browser → Seamonkey

Comment 6

9 years ago
Cannot confirm this bug with Seamonkey 1.1.11 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 SeaMonkey/1.1.11).
Suggesting RESOLVED/WORKSFORME.

Updated

6 years ago
Assignee: dbienvenu → nobody
Resolving WORKSFORME based on comment #6 and on no reaction from anyone in the 3 years 5½ months since then.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.