small animated GIFs still do not animate properly (some frames moved to the left at 1-2px, resulting image distorted)

RESOLVED DUPLICATE of bug 160186

Status

Core Graveyard
Image: Painting
RESOLVED DUPLICATE of bug 160186
14 years ago
8 years ago

People

(Reporter: Sergey «Mithgol the Webmaster» Sokoloff, Assigned: Jim Dunn)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8

I had a hope that bug 242691 ("Animated gifs do not animate properly") addressed
most of problems with GIF animation; however, having downloaded the latest
Release Candidate of Firefox (which was 0.9RC), I lost my hope. Animated GIFs
still do not animate properly. I know that's what RCs are for, and maybe we'll
enjoy 0.9 release with this bug already fixed -- who knows.

Be warned: this is a mosty nasty kind of rare bugs, which sometimes happen and
sometimes does not happen. A collection (and not too small) of animated GIFs is
needed to demonstrate. As with 13th comment to bug 160186, this one bug much
easier happens on small animations, rarely happens at bigger animated images.
Probably bug 160186 is the same bug, but the case I observed just didn't fit
into bug 160186's summary ("animated GIF moves 1px right during animation"), so
I'm entering a new bug in the sake or those GIF frames which move to the left
(this bug) instead of moving to the right (bug 160186). When debugged, they all
anyway will not move anywhere.

What example do I have? The guestbook of my own website, where I made all that
images myself. Almost every time I can reproduce the problem here.

Reproducible: Always
Steps to Reproduce:
1. Open
http://xbase.ru/guestbook/index.php?id=ud1wv4mxp75ymchxypwwugn6g8uw2gs0&rnd=3791&login=mithgol&design=0&m=0
in your Gecko-based. As for me, I prefer Firefox.

2. You see a typical guestbook form for a guestbook entry, with more than 30
smiles (also known as emoticons). Some of them are animated GIFs.

3. As some frames of animated GIFs display 1-2px right of their expected
position, several smiling faces are distorted. Most often (almost every time)
these are:

1) a face that yawn;
2) a shocked staring face (the 11th, counting left to right);
3) a face that ROTFL (rolls on the floor laughing).

4. Some GIFs are autofixed when you mouseover them, but broken again in the next
animation loop. This effect, however, is not guaranteed.

5. Almost every time every broken GIF is observed fixed when you view it alone
(right click --> View Image). That's why a collection of images is needed to
demonstrate the bug.  Also note that HTML width="15" and height="15" attributes
were set according to intrinsic image resolution, so that's not the reason for
image to be broken in collection and autofixed when viewed alone.
Actual Results:  
When on webpage, some frames of animated images are moved to the left, without
respect to their intrinsic relative coordinates -- maybe, to the left edge of
GIF image's canvas? The observed case may indicate frame X coordinate (relative
to 0,0 of GIF image's upper left corner) being erroneously zeroed somewhere.

When accessed directly by image URL typed in address bar, GIF animation is not
broken.

Expected Results:  
Not broken animation is expected.

This bug never happens when each frame of animated GIF has the same dimension of
the whole image, and when each frame has intrinsic relative coordinates 0,0.
However, it is not unusual for a GIF author to reduce filesize by cutting out
those parts of frame image which were not modified since previous frame.

The two of bugs that seem most related IMHO:

bug 242691 -- Animated gifs do not animate properly
bug 160186 -- animated GIF moves 1px right during animation

Comment 1

14 years ago
WFM on Mozilla Build 2004061308 & WinXP. (same behavior as IE)

Comment 2

14 years ago
WFM on Mozilla 20040610 on Linux.

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 160186 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

8 years ago
Component: Image: Painting → Image: Painting
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.