Drop down combos grow each time an element is selected

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: osavill, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040610
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040610

I will attach a zip file with the HTML / PHP in it. Each time an option is
selected from any of the drop downs the drop down width increases a little. This
behaviour stops when the drop downs reach the right hand browser edge so no
scrolling is needed.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
The drop downs should remain a constant width. The browser should decide a width
based on the HTML and stick to it.
(Reporter)

Comment 1

14 years ago
Created attachment 150708 [details]
Files for self growing drop downs
(Reporter)

Comment 2

14 years ago
The CSS for the drop downs is "select { width: 100%; border-style: solid;
border-color: #bacae1; border-width: 1px; color: #19519d;  font-size: 0.7em;
font-family: arial, helvetica, sans-serif;  }". Removing the 'width="100%"' from
each of the table cells containing the <select...> 'fixes' the problem. So does
setting each table cell as 'width="110%"', but then this breaks IE ! Setting the
table cell width to 120% causes the entire table to fill the free space up to
the browser right hand edge. Setting the table cell width to less than 100%
causes the growth effect to be magnified ! So by the time the table cell is at
'width="50%"' the drop down growth effect is huge !! So this looks like some
kind of contention between the table cell specified width and what CSS is saying. 

It is my understanding that the table cell width specifies how much of the free
space the cell is going to occupy, whereas the <select...> CSS width specifies
how much of the table cell to occupy.

Although it is a workaround to remove the table cell's width statement this
might not always be convenient so this is still a bug. For once IE's behaviour
appears to be spot on in this scenario.

Comment 3

14 years ago
WFM LInux 2004072607 I did notice you have a link to a css file that was not
included in your zip file. 
Next time please do not submit testcases that include PHP and the like unless it
is necessary.
(Reporter)

Comment 4

14 years ago
> WFM LInux 2004072607 
And for me know !! 
 
> I did notice you have a link to a css file that was not included in your zip 
> file. 
I included the CSS statement for the <select>, but I will remember the CSS 
file next time. 
 
> Next time please do not submit testcases that include PHP and the like 
> unless it is necessary. 
Sorry about that, I should have done a "View Source" of the rendered page and 
attached that. I will do that next time. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.