<select> ignores background-color style attribute for selected value

RESOLVED DUPLICATE of bug 79107

Status

RESOLVED DUPLICATE of bug 79107
15 years ago
14 years ago

People

(Reporter: osavill, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040610
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040610

The following HTML snippet produces a drop down with coloured bars in both IE
and Mozilla :
<select>
 <option value='noact' style='background-color: magenta;' selected='true'>Text
foreground colour</option>   
 <option value='#FFFFFF' style='background-color: #ffffff;'></option>   
 <option value='cyan' style='background-color: cyan;'></option>
</select>

In IE the initial state is a Magenta bar and, once the focus is removed from the
drop down !, the entire drop down becomes the colour of the selection. In
Mozilla this does not happen, The drop down remains starts white and remains white. 

This maybe down to me using the wrong style attribute, in which case many
appologies. I based this observation on what IE does.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 79107 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.