account manager account list needs some cleanup

RESOLVED DUPLICATE of bug 505465

Status

SeaMonkey
MailNews: Account Configuration
RESOLVED DUPLICATE of bug 505465
14 years ago
9 years ago

People

(Reporter: Bienvenu, Unassigned)

Tracking

({qawanted})

Trunk
x86
Windows 2000
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
It's possible to get the account list pref into a state where it has invalid
accounts. It's also possible to get account keys re-used, when it really
shouldn't be, because we write out the account key in the headers of incoming
pop3 mail.

e.g., if you delete your last account (say account3), and then read mail in the
local folders inbox that came from account 3, we'll ask the account manager for
that account by account key, and AM will create account3 again! Or, instead, if
you create a new account after deleting the last account, it will get assigned
the key account 3.

So, I need to make FindAccountByKey not create a bogus, empty account, if the
account doesn't exist, and I need to make the AM remember the highwater account
key, and not re-use accountkeys. To initialize the highwater, we'd check if that
pref exists, and if not, set it to the current highwater. Going forward, we'd
increment it whenever creating a new account, and use the current highwater+1
for the new account key.
(Reporter)

Comment 1

14 years ago
We should also clear out server prefs before creating a new server, in case
there are server prefs but no server defined because no account was hooked up to
the server.
Product: Browser → Seamonkey

Comment 2

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
(Reporter)

Comment 3

9 years ago
I rather wonder if this has been fixed or not - I think there's a dup of it as well...
Assignee: bienvenu → nobody
Ever confirmed: false
Keywords: qawanted
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 505465
You need to log in before you can comment on or make changes to this bug.