Ctrl + right arrow doesn't advance to next word as expected

RESOLVED DUPLICATE of bug 142120

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 142120
14 years ago
10 years ago

People

(Reporter: Radovan Bukoci, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; sk-SK; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; sk-SK; rv:1.7) Gecko/20040514

Ctrl + right arrow should move cursor before the first letter of next word, once
at a time. So, for example, sentence containing 10 words should be "passed" by
10 Ctrl + right arrows. 

The bug is: it moves to the end of this word, and only the next Ctrl + right
arrow moves to the beginning of next word. SO, the sentence containing 10 words
is  "passed" by 20 Ctrl + right arrows.

Notes: 
1. in Windows I think there is no bug. Only in Linux.
2. Funny, Ctrl + left arrow works without bug too. Only Ctrl + right arrow is buggy.

Reproducible: Always
Steps to Reproduce:
1. Open Compose window
2. into the big text area, type a usual sentence with words divided by spaces.
3. try to play with Ctrl + right arrow. It behaves as described above in "Details".




this bug is not new, I observed it long time ago (half year minimum). But I was
too lazy to report it before (hoping that anybody else would report it).

   Thanks.

Comment 1

14 years ago
It seems this was reported and already fixed, see bug 142120. According to your
build id you should not have this bug, maybe you can comment/reopen the other bug.

See also bug 92850, maybe it's this one that you see.
(Reporter)

Comment 2

14 years ago
Oh, You are right, my bug is exactly 142120 (moreover, in 142120 the bug is
better described than I described it). 
I am sorry I couldn't find it thru the Search (I sought "Ctrl arrow").

Bug 92850 is something different, I cannot reproduce it on my system (but I
don't mean the bug is void, maybe I only didn't try hard enough).

Now I would like to (IN THIS ORDER, PLEASE):
1. Find someone to confirm this bug
2. Reopen 142120
3. Mark 246716 as duplicate of 142120
4. Optionally, ask for setting 142120 as blocker of 1.8.b

Please, [let me know how to] or [help me to] accomplish it.

(Reporter)

Comment 3

14 years ago
Yes, this bug is duplicate of bug 142120, which is resolved (although not fully,
in my opinion, but I will discuss it in 142120).


*** This bug has been marked as a duplicate of 142120 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.