backups.number_of_prefs_copies in prefs.js does not work

RESOLVED WONTFIX

Status

SeaMonkey
Preferences
RESOLVED WONTFIX
14 years ago
13 years ago

People

(Reporter: World, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040613
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040613

Even though I set backups.number_of_prefs_copies = 7 in prefs.js, no back up of
prefs.js was created(prefs.bak nor prefs.bakNN) these three months.
This caused difficulty in manual recovery from prefs.js corruption by Mozilla's bug.

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
Confirming with latest 1.8a1/1.8a2 trunk builds on WinNT 4.0.

Comment 2

14 years ago
I found it! The pref is now obsolete. I will file a bug for the removal of it.
http://lxr.mozilla.org/mozilla/search?string=number_of_prefs_copies

The pref was introduced by Bug 98476, but was backed out with fixes for Bug
132517 (for problems see Bug 228888), later improved by Bug 250092. As I
understand it, there is no need for the backups anymore.

So this bug could IMO be resolved.

Comment 3

14 years ago
wontfix per bug 253259.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
*** Bug 272195 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.