If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Document the Mozilla build system

RESOLVED DUPLICATE of bug 134478

Status

Developer Documentation
General
--
major
RESOLVED DUPLICATE of bug 134478
14 years ago
5 years ago

People

(Reporter: Brian 'netdragon' Bober, Assigned: cls)

Tracking

Details

(Reporter)

Description

14 years ago
With the modifications to the Mozilla build system, especially cross-compiling
and mingw/cygwin support (i.e. environment vars, configuration utils, */build
and */config directories plus root dir). its hard to make heads or tails of the
buildsystem (for instance, when should nsinstall build, etc?). This impedes
porting, packaging, and 3rd party modifications to the build system. We need
documentation on Mozilla.org, along with better documentation of the makefiles
and configuration files.

Also, with a properly documented buildsystem, people would have more incentive
to work on it to improve it and also make it work with autoconfig 2.5

A requirement for further checkins can be keeping the documentation up to date.
(Reporter)

Comment 1

14 years ago
Comments in the code would be a helpful start.
(Assignee)

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 134478 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Component: Mozilla Developer → Documentation Requests
Product: Documentation → Mozilla Developer Center
Component: Documentation Requests → Documentation
Product: Mozilla Developer Network → Mozilla Developer Network
Component: Documentation → General
Product: Mozilla Developer Network → Developer Documentation
You need to log in before you can comment on or make changes to this bug.