anchor tag with alert() doesn't work.

VERIFIED DUPLICATE of bug 98185

Status

()

VERIFIED DUPLICATE of bug 98185
15 years ago
15 years ago

People

(Reporter: bhauber, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

According to the W3C standards, href is not a required attribute for an anchor
tag.  The webpage I provided is a sample of something I've come across on a
couple websites... An anchor tag, with an onClick attribute but no href.  IE and
Opera both render this fine and when you click on the text, the alert window
pops up.

Reproducible: Always
Steps to Reproduce:
1. Go to the page.
2. Attempt to click on the text


Actual Results:  
Nothing happens.

Expected Results:  
A JavaScript alert window should pop up.

Comment 1

15 years ago
Your testcase shows an error because there is no argument in the alert()
function.  This issue has been recognized previously but ruled a WONTFIX issue.
 See bug 98184 comment 3.

*** This bug has been marked as a duplicate of 98185 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Status: RESOLVED → VERIFIED
Component: Web Site → General
Summary: anchor tag with no href doesn't work. → anchor tag with alert() doesn't work.
You need to log in before you can comment on or make changes to this bug.