Closed Bug 246756 Opened 18 years ago Closed 18 years ago

Firefox bookmarks do not lead to u.m.o for themes extensions

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Firefox1.0beta

People

(Reporter: Peter6, Assigned: tmeader)

References

Details

(Keywords: fixed-aviary1.0)

Attachments

(2 files)

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Bookmarks->Firefox & Mozilla Information->Firefox themes does not lead to
http://update.mozilla.org/themes/?application=firefox (but texturiser)

Bookmarks->Firefox & Mozilla Information->Firefox extensions does not lead to
http://update.mozilla.org/extensions/?application=firefox (but texturiser)



Reproducible: Always
Steps to Reproduce:

Actual Results:  
end up at texturiser.net with incompatible extensions

Expected Results:  
end up at update.mozilla.org
request ?0.9
Flags: blocking0.9?
0.9 is released.  Cleared 0.9 flag, set 1.0 flag instead.
Flags: blocking0.9? → blocking1.0?
OS: Windows 2000 → All
Hardware: PC → All
How about redirecting to the correct url?
update.mozilla.org isn't ready yet, which is why ben didn't update the links.
Since that site is live now, I've gone ahead and updated the bookmarks.
Comment on attachment 151341 [details] [diff] [review]
Quick and easy fix for the bug.

Setting for review.
Attachment #151341 - Flags: review?(p_ch)
Comment on attachment 151341 [details] [diff] [review]
Quick and easy fix for the bug.

pch won't be around for an unknown period of time.  This is a good thing, I'll
try to land this some time this week. (Busy with work)
Attachment #151341 - Flags: review?(p_ch) → review+
Flags: blocking1.0? → blocking1.0+
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → Firefox1.0beta
Shouldn't the bookmark links specify the GUID as the "application" rather than
the generic "firefox" like the "Get More Themes" and "Get More Extensions" links do?
Not going to obsolete the old one, since I'll leave it up to the person who
checks it in to decide which to use. But either way, here's the patch using
GUID instead.

Thanks.
Comment on attachment 151633 [details] [diff] [review]
Now using GUID for Firefox instead of the name.

New patch (not necessarily "better") to use the GUID of Firefox in the bookmark
instead of the name. Both will work. Take your pick when checking in.
Attachment #151633 - Flags: review?(mconnor)
*** Bug 247302 has been marked as a duplicate of this bug. ***
Assignee: p_ch → mconnor
Flags: blocking-aviary1.0RC1+
Attachment #151633 - Flags: review?(mconnor) → review+
Assignee: mconnor → tmeader
used the GUID version of the patch, fixed branch and trunk.  Thanks Tim!
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Whiteboard: fixed-aviary1.0
switching fixed-aviary1.0 to keyword, for searching purposes.
sorry for bugspam.
Keywords: fixed-aviary1.0
Whiteboard: fixed-aviary1.0
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.